errors in functions.sh in 1.3.x



  • Server
    • FOG Version: 1.2.0
    • OS: debian 8.6
    Client
    • OS: windows 7
    Description

    Hi
    I want to update fog 1.2.0 to 1.3.0. I downloaded the 1.3.0 fil, uncompress it and try to launch the installfog.sh. I have the following error :

    root@fogserver:~/fogproject/bin# sh installfog.sh
    installfog.sh: 20: installfog.sh: [[: not found
    installfog.sh: 84: …/lib/common/functions.sh: Syntax error: “(” unexpected (expecting “fi”)

    I tried to update as tell in the upgrade to trunk post, but i have the same error. I opened the functions.sh script with nano to check the code, but i have see nothing at these lines.
    How to know the lines concerned by these errors ? Are the lines 20 and 84 really the concerned lines or some includes files can modify the number line shown in the message ?



  • ok, thanks


  • Moderator

    sh is more limited than bash ./ automatically chooses the right tool to execute it (if available)


  • Senior Developer

    You should never be running the script as sh installfog.sh

    You should run it either as: bash installfog.sh or simply ./installfog.sh


Log in to reply
 

455
Online

38949
Users

10700
Topics

101523
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.