problem with delayed tasks



  • Hi,
    I’m testing fog since few days. Il have a problem with delayed tasks. They don’t start automatically. In this afternoon, i create for a pc a download task and a wake up task at the same time. Dyue to the fact the pc doesn’t start, i powered it on, and go to the pxe menu, but the task doesn’t start. What to do in the fog pxe menu to start the task ? May the pc be started for the download to start ?


  • Senior Developer

    @Ric41 Once the time is updated, the services have no clue until they are restarted.

    service FOGMulticastManager restart
    service FOGScheduler restart
    service FOGImageReplicator restart
    


  • i already have set the timezone. I’ll update fog in the day


  • Senior Developer

    @Ric41 If you absolutely must use 1.2.0, you may find better luck by editing the /etc/php.ini file (I believe it is under /etc/php5/php.ini for Debian).

    Look for the ;date.timezone = entry

    Remove the ; from the line and change for your appropriate timezone. For example:

    If you live in New York, you would have an entry like:
    date.timezone = America/New_York



  • @Wayne-Workman said in problem with delayed tasks:

    With you being new to fog, there is no reason why you shouldn’t be running the latest version.

    because i installed fog before christmas


  • Moderator

    @Ric41 debian 8 will run fog 1.3.0 nicely. Please do me and you a favor and upgrade to 1.3.0.

    You can follow official instructions for this or grab the latest development version via wiki.fogproject.org and searching for “upgrade to trunk”

    With you being new to fog, there is no reason why you shouldn’t be running the latest version.



  • Sorry, i use fog 1.20 on a debian 8 and php 5.6 server.
    I already verify the time, that is correct. The timezone wasn’t defined, but the timezone taken by php was correct. I don’t have any TZ_INFO setting in fog, but the launch time of the instant tasks is correct in fog.


  • Moderator

    Make sure the time on your server is correct. Make sure the timezone on the server in the OS is correct, make sure the timezone in the web interface is correct.

    You didn’t share what OS your fog server is running on, so I couldn’t offer you any exact commands for setting the time in the OS. But you can set your PHP timezone in the web interface at FOG Configuration -> FOG Settings -> General Settings -> FOG_TZ_INFO

    Also look at your logs inside of FOG Configuration -> Log Viewer -> Scheduler


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.