SOLVED Cannot capture ThinStation PC image "No resizable partitions found (/bin/fog.upload)

  • Server
    • FOG Version: 7853
    • OS: Ubuntu Server 14 (VM)
    • Service Version: none?
    • OS: ThinStation (Linux general)

    Really hope you guys can help me here, I’m completely stuck. I can PXE boot the client no problem and FOG says the machine is compatible. However, when I try a standard “capture” of ThinStation (OS is on hard drive) I get:

    "Getting Windows/Linux Partition Count.........Failed
    An error has been detected!
    No resizable partitions found (/bin/fog.upload)
        Args Passed:
                                 Computer will reboot in 1 minute"```

    So I tried a debug-capture, but I’m not sure what to do there. After reading this thread, I tried “fixparts /dev/sda” but I must have done something wrong because it didn’t work. Any help greatly appreciated. Thank you!

    Mod note: fixed formatting.

  • @Tom-Elliott Yes, that worked! THANK YOU!!

  • @george1421 Hey George! It’s CrimsnKdA from SW. I have a old Optiplex 755 with just 1GB of RAM and a 40GB HDD and ThinStation is flying on it with our setup. I know it’s not ideal, but it’s cheap is works with what we already have. I have it pretty much tweaked perfectly for us now, getting FOG imaging working with it was the last piece here. Thanks!

  • @Tom-Elliott Yes, that worked! THANK YOU!!

  • Moderator

    While this is really off-point here, why are you running thinstation from a hard disk drive?

    We will typically use a tiny usb drive (like sandisk cruzer fit) and pull the HD and disconnect the cdrom (if not needed) from systems. The other option is we will pxe boot into thinstation depending on the environment.

    I’d have to look at the disk on devstation to see, but I think its ext3 or ext4 format so fog should capture it.

  • Try changing the “type” of image (resizable currently) to “not resizable”.