Unable to change FOG Configuration -> Fog settings (Error 500)



  • Server: Ubuntu 10.04LTS
    OCS: 1.3.1-RC-2

    Sorry if my english is not as good as I want, i’ll try my best to explain myself…
    Well lets start…
    I’ve updated from FOG 1.2 to 1.3.2-RC-1, and now I have 3 problems (I put them here because maybe some other people is having them and this will help):
    1- Big one, cant change anything inside FOG Configuration -> Fog Settings, not Proxy, AD defaults…
    But i can change things on the other menus like iPXE boot menu etc etc.
    2- Error when sending inventory to our FOG server.
    SOLVED updating to 1.3.1-RC-2
    3- Progressbar of deployment not working
    SOLVED updating to 1.3.1-RC-2

    So main problem now is being imposible to change FOG Settings, error is HTTP ERROR 500.
    It worked well on 1.2, so I assume that something is not working well.
    EDIT: I’ve opened /var/log/apache2/error.log and found this:
    [Wed Jan 04 13:45:22.984584 2017] [php7:error] [pid 11468] [clientip:60689] PHP Fatal error: Uncaught Error: Using $this when not in object context in /var/www/html/fog/lib/fog/fogbase.class.php:1922\nStack trace:\n#0 /var/www/html/fog/lib/pages/fogconfigurationpage.class.php(1884): FOGBase::setSetting(‘FOG_CLIENT_BANN…’, ‘’)\n#1 /var/www/html/fog/lib/fog/fogpagemanager.class.php(256): FOGConfigurationPage->settingsPost()\n#2 /var/www/html/fog/management/index.php(49): FOGPageManager->render()\n#3 {main}\n thrown in /var/www/html/fog/lib/fog/fogbase.class.php on line 1922, referer: http://serverip/fog/management/index.php?node=about&sub=settings

    Any idea?

    Thanks forward!


  • Senior Developer

    Please repull and install. Missed it when I switched it to a static method.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.