Storage Node (TFTP/iPXE) won't connect and client ipxe client errors



  • I’m having a few problems and my guess is that it stems from not being able to connect to the main fog server, but I would like some advice if possible.

    Main FOG server v 1.3.0 Ubuntu 14.0.4 LTS
    Storage Node v 1.3.0 Ubuntu 14.0.4 LTS

    When I first installed the storage node I saw the graph on the main page loaded for a short time and now I cannot get that back for the life of me. *note I did upgrade both nodes since then

    After the install I added created a storage from the main server and have triple checked to ensure all creds were correct.

    I have also tried booting a client which throws an input/output error Could not boot 1d0c6439 and Chainloading failed, but ‘s’ allows me to enter an iPXE shell. I’ve also tried manually browsing to http://fogserver-storagenode/fog/service/ipxe/boot.php and receive the following, which also leads me to believe this all comes down to connecting to the main fog server.

    “A valid database connection could not be made”#!ipxe
    set fog-ip
    set fog-webroot
    set boot-url http://${fog-ip}/${fog-webroot}

    The one thing I was unsure of and could not find an answer on was how the storage node and main server communicate.

    Does the main fog server directly reach out to the storage node or does the storage node ONLY initiate and setup the tcp communication?

    I currently have a Source NAT in place for the storage node to get to the main server, but not the other way around, could this be my problem?

    As always any advice is more than welcome and thanks in advance.

    James


  • Moderator

    This document more throughly describes all of fog’s passwords, where to set them, what they do, and and so on:
    https://wiki.fogproject.org/wiki/index.php?title=Password_Central

    Also, for this particular problem, this article may also help future readers:
    https://wiki.fogproject.org/wiki/index.php?title=Troubleshoot_MySQL


  • Senior Developer

    Remoted in and found a few of the issues was related to mysql, the fogstorage username/password, and was able to correct these all.

    Thank you @SlimJim for the time to help out.


  • Senior Developer

    @SlimJim Okay, I’m waiting whenever you’re able.



  • Ok, the storage node was added and now shown on the home page graph. I am still unfortunately receiving the ipxe boot errors along with the error when I browse the the storage node ipxe/boot.php service url. I have to step away for 10, but will be available after that


  • Senior Developer

    @SlimJim Just trying to hit you up on chat.


Log in to reply
 

381
Online

39198
Users

10850
Topics

103281
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.