MacPro6,1 PXE boot



  • I have a number of Mac Pro late 2013 models I’m trying to PXE boot, but can’t get it to work.

    Pressing the Alt key on boot shows no network option. Have ipxe.efi in the Bootfile Name.

    Anyone any ideas? Thanks


  • Moderator

    @chief Ok if you put a dumb switch in between the target computer and building switch and it resolved the problem. Then its probably one of the advanced protocols causing the issue.

    This is typically spanning tree being enabled and not using one of the fast stp protocols.

    Or you have green ethernet (802.3az) enabled on the building switch. We’ve seen this to be an issue with some realtek nics.



  • @george1421 Putting a dumb switch in between fixes the issue.
    We have Dell switches with portfast enabled and a bpdufilter. After a bit of googling, I think the bpdufilter should allow the dhcp through the switches.



  • @george1421 Thanks for help. Was off for a few days over the holiday period.

    Yes, Windows 2012r2 DHCP server. The FOG server and PXE client are on same VLAN/Subnet.

    Will test the network issues.


  • Moderator

    @chief Its been a few days now so lets make sure we are on the same page.

    You have the dhcp server (MS Windows??), the FOG server, and the PXE booting client all on the same vlan for testing.

    The target computer PXE boots, then the iPXE kernel is sent to the target computer. But now iPXE complains about “No configuration methods succeeded”

    If this is the case, my initial reaction is that this might be a spanning tree issue (assuming this happens on the dell computer).

    Why?, because the target computer pxe boots and the undionly.kpxe (or ipxe.efi) is sent to the target. computer. To do that the PXE rom must be able to talk to the dhcp server to get an IP address and boot file name. When the iPXE kernel launches it momentarily resets the network interface causing the link light to drop (wink) for a second. If spanning tree is enabled on that switch port and it is not configured for one of the fast STP protocols, the port won’t go into the forwarding state for 27 seconds. By then the iPXE kernel has given up stating “No configuration methods succeeded” or in english - “I can’t get a dhcp address on any network interface”.

    A quick check for a spanning tree issue is to place a dumb (unmanaged) switch between the target computer and the building network switch. If it boots into the FOG menu with the unmanaged switch in line then you need to speak to your networking group to confirm that one of the fast STP protocols are enabled. This is not a FOG issue but a networking issue.



  • @george1421 I have moved the FOG server into the same VLAN and IP subnet. I have the DHCP set up as per the BIOS and UEFI co existence post. I am now getting PXE boot on windows, but it fails with a “No configuration methods succeeded”

    Capture

    The screenshot is from Virtualbox, but I’ve tested on phyical Dell laptops with same issue.


  • Developer

    @chief I am wondering if you are aware of the wiki article: https://wiki.fogproject.org/wiki/index.php/FOG_on_a_MAC

    As you see there is a kind of special DHCP setup to be able to netboot MACs. There is more to it than simple DHCP - see here https://static.afp548.com/mactips/bootpd.html. I am not aware of windows DHCP server being able to do this.

    A different approach would be to bless your MAC clients - setting to boot option to get a boot image from a hard coded TFTP server. Find a short description in the wiki article mentioned above.


  • Moderator

    @chief said in MacPro6,1 PXE boot:

    It is going between subnets. From server to PC subnets/VLAN.

    Is it possible for this test to get all three on the same subnet. We really need to the entire conversation here. If that isn’t possible, can you setup a wireshark system on the Mac/workstation subnet and collect a pcap of that workstation pxe booting. From this perspective we only need port 67 and port 68 data. We know from the fog server that the file is being requested. We just need the part of the conversation that leads up to the request.



  • It is going between subnets. From server to PC subnets/VLAN.


  • Moderator

    I guess he could always just do a wireshark capture on the dhcp server.

    I guess what would be the ultimate best is a third computer connected to the same computer network booting via a hub (not a switch). Just stick the hub between the target computer and the building’s network port, then use one of the hub’s spare ports to do a capture with. This will not work with a switch, only a hub would do it.


  • Moderator

    @chief I also see only the tftp request. One is asking if the file exists and the second requesting the download of undionly.kpxe (which we know is only for bios based systems).

    Is your dhcp server, fog server and booting target computer on the same subnet (vlan)? That is a requirement if you want the FOG server to listen in on the dhcp messages.



  • I have changed the DHCP environment to bios and uefi. So this windows PC should boot to the bios undionly.kpxe

    We only have one DHCP server. No dnsmasq


  • Moderator

    @chief All I see is two read requests for undionly.kpxe which is not what we should see if indeed your DHCP server’s option 067 is set to ipxe.efi because if it was, we would see requests for ipxe.efi and not undionly.kpxe

    Do you have more than one DHCP server in your environment? is dnsmasq running anywhere?



  • I think the issue is with something else. The cable is connected. DHCP for OS working fine.

    On booting a windows pc I get “No configration methods succeeded”

    The pcap file on the windows pc booting is here
    https://drive.google.com/file/d/0B1xRaaq2F0-JNUhXb3N2UTZSRm8/view?usp=sharing


  • Senior Developer

    Is the Mac connected to the network? (preferably via cable as PXE over wifi isn’t something I’m aware of as being possible with the netboot environment)


  • Moderator

    George, I’m stealing your post.

    @george1421 said in PXE seems to work but Fog Cloning menu not displayed.:

    OK I want you do this this process.

    1. Install tcpdump on your fog server.
    2. key in the following command on your fog server console. tcpdump -w output.pcap port 67 or port 68 or port 69 or port 4011
    3. When tcpdump starts, then pxe boot your target computer until you reach the error.
    4. On your fog server press ctrl-c to exit the tcpdump program.
    5. Either review this pcap file in wireshark or post it here an I will take a look at it. If you don’t have enough credits the FOG Forum may keep you from uploading the pcap file here, so you will then need to use something like dropbox, box.com, or a google drive and share out the pcap file.

  • Moderator

    @chief said in MacPro6,1 PXE boot:

    the option 067 is set to ipxe.efi at the moment.

    If that’s the case - something else is wrong. We should probably do a packet capture on the fog server to see what it is seeing. Give me a minute and I’ll find the command.



  • @Wayne-Workman the option 067 is set to ipxe.efi at the moment.

    Will set up like the guide. Do I just need to add PXEClient:Arch:00002 etc or others for a MAC?


  • Moderator

    @chief It’s probably not getting a valid efi file to boot with. Follow this guide to setup bios & uefi co-existence on your dhcp server: https://wiki.fogproject.org/wiki/index.php?title=BIOS_and_UEFI_Co-Existence

    For a simple test, you can just change option 067 to ipxe.efi - but don’t be a slacker and manually change it every time you need it, that’s lame. Use the above guide.



  • No. First time testing a mac. Fog server on version 1.3.0-RC-36.
    It works for PCs. DHCP is controlled by a windows 2012r2 server.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.