• Hello Tom,

    I have fog 1.3.0 (R26) running on Ubuntu 14.04. Everything works fine and I am trying to do snap. I created a batch file, this batch will copy 2 files from network drive and place them in windows/temp folder. Batch script work running manually.
    I created a snap in (Normal),Select Snap in Template = ’ batch script," Snap in runwth(defaulted to “cmd.exe”), uploaded the batch script, snapin Argument is blank(Like to see for the testing purpose).

    I attached to Host and from Basic Task–>Advance Task–>Single Snapin.

    It take logn to load but I get an error message ‘Hash not found’. I like through forum and followed it but no luck. I am not sure why it would not work. Any help is greatly appreciated.

    Thank you,


  • @Olduser are you creating a pack or a normal snapins?

  • Tom,Wayne&THEMCV,

    All of you, Thank you for quick reply. I resubmitted snap in to host. Snapin showed hash file at bottom. Advanced Task showed snap queued in and Checked in but file does not displayed in [FOG_SNAPIN_PATH]. I will try to upgrade and let you know.



  • @Wayne-Workman Just for clarity, RC-26 is when this new service was added.

  • Also it wouldn’t hurt anything to move to the latest RC as well. I don’t remember which RC the 30-minute hashing thing was added, but it wasn’t too long ago.

  • FOG Snapins are hashed automatically every 30 minutes automatically. They should also get hashed when you upload the file though. Changing out the filename though (using the Snapin Exists) mode should reset the hash to blank as the snapin contents have changed. If you wait for the 30 minutes the snapin hash should be generated.

  • Reupload your file in the snap-in. Make sure your settings are right (and that the script runs silently, FOG Client doesn’t like it when snap-ins don’t) and re-upload the batch file.

    I’m guessing your file size is 0ib on the left. Try that and let me know.