Host Already Registered and MemTest issue



  • Hi all,

    I promised an update with our new Precision T3500 server, however I’m experiencing a few little niggles that have distracted me from the overall performance of the server so far, and I’m hoping somebody here can shed some light on them.

    These queries are now completely different to the original post title, so please let me know if you would like me to create a new topic.

    The first thing I have come across which is rather strange, is that a Full Host Registration and Inventory will not create a deploy task when asked to. So I type in the Host name, and the image ID I want assoiating with the host, I skip all other parts by hitting enter as they don’t apply to us, and then when asked if I want to deploy now I hit “y” and then enter the username and password. I notice it saying, “Done, with imaging”, and it also says
    "Attempting to register host…
    Host already registered as %Host name I just specified%". (I’m not sure if it always says this or not even when working normally)
    It definitely hasn’t already been registered, I even cleared all the hosts off the server and tried again. This also happens when trying the Quick Host Registration and Inventory (Yes, I have ticked the box to autopopulate and selected a default image on the Web UI).
    The only way I can get a host to image is by selecting the “Deploy Now” function on the PXE boot menu. This is of course a very quick and useful way of deploying an image to a machine, however the inventory report is extremley useful to us in cases of future technical support issues with that machine.
    Does anybody know what could be causing this? It worked fine on the Optiplex 380 server I mentioned previously on this thread, and I am extremely confident I have set up the Precision identically.

    The second issue prevents us from doing a memtest on the host machine. It has only happened on 2 or 3 laptops so far (all of them HP), and one of them was eventually able to boot memtest after a BIOS reset.
    I have provided a picture of the screen with the error message on below -

    alt text

    Does this make sense to anyone?

    Mod Note: This topic has been forked from here:
    https://forums.fogproject.org/topic/9039/very-slow-unicast-deploy-when-imaging-2-or-more-machines


  • Senior Developer

    For the already registered what version of fog are you running?

    For the kernel panic, maybe there’s a firmware update for these? Also, how are the clients booting to the menu (efi or bios?? I suspect potentially problem in efi boot code.)


  • Moderator

    For the registration issue, see this:
    https://wiki.fogproject.org/wiki/index.php?title=Troubleshoot_MySQL#Hosts_think_they_are_not_registered_.2F_can.27t_register_.2F_Already_Registered_.2F_other_weirdness

    Also, @Tom-Elliott what would you think about putting those clean-up commands into the installer as an option? the -c lower case isn’t taken yet, that could be “Clean out invalid DB data”


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.