SOLVED Backing up database... Failed!

  • Server
    • FOG Version: 1.3.0
    • OS: Centos 6.8 64-bit

    Hi. I’ve been setting up a new fogserver. it’s virtual one with vmware.
    I installed CentOS, updated the system, and installed Fog 1.3.0.
    First, the webGUI would show, stated that I had php version 5.3.3, and I needed at least 5.5.5, so I updated php to 5.6. Easy. the webgui works, I can log in and everything.
    then, I updated the svn, and ran ./ again. Now it failed on php. so, I uninstalled 5.6, and fog installed the 5.3.3 version for me again. Now, here’s the problem;
    Backing up Database… Failed!
    I can’t get past that, and the webgui is just blank, no error or anything.
    I updated php to 5.6 again, but it didnt make a difference.
    I have tried to stop/start mysql service, I’ve tried uninstall/install mysql, but nothing.
    Still wont work.
    Any ideas?
    PS: I have a snapshot from before I updated SVN, where the webgui works.

  • Try this:

    sudo rpm -Uvh epel-release-6*.rpm
    sudo rpm -Uvh remi-release-6*.rpm

    Then retry installing FOG.

  • @WourN The installer should have taken care of it for you (but most people installing fog tend toward fresh which means they’re likely installing CentOS 7). Basically, those commands downloaded and installed the repositories FOG is supposed to be installing for you.

  • @Tom-Elliott Sorry I was at lunch.
    But Elliot, you are a legend. It works now. No errors, and the webgui works. Gonna make a new image and try upload/download and all that.
    I’m not good with linux in general, what did those commands do exactly?

  • I know I need to be patient, but did you try the commands I just posted?

    sudo rpm -Uvh epel-release-6*.rpm
    sudo rpm -Uvh remi-release-6*.rpm

  • @Tom-Elliott @Quazz
    Running yum update or yum install php will install the 5.3.3 version. If I let fog install php, it will still be the 5.3.3 version.
    I found a way to install 5.6, so that the webgui could work. But running ./installfog with the 5.6 installed, results in Php… Failed!
    Anyway, I’ve remove the packages line from fogsettings, but I’m still getting failed on backing up database

  • Try this:

    sudo rpm -Uvh epel-release-6*.rpm
    sudo rpm -Uvh remi-release-6*.rpm

    Then retry installing FOG.

  • @WourN What do you mean?

    “Failed!! as expected because I have the 5.6 version.”?

    That is supposed to be the case.

  • Moderator

    @WourN I believe this is an issue due to Centos 6 officially only supporting PHP5.3 so that’s what’s in the default repo. However, FOG should be able to install the correct version.

    Only thing I can think off is that you have to remove the packages= line from /opt/fog/.fogsettings

  • @Tom-Elliott @quazz All right so now I ran installfog.
    I got the php… Failed!! as expected because I have the 5.6 version.
    so I uninstalled it, and now it’s installing the 5.3.3 version again.
    So, running ./ right now, and Backing up database… Failed!!
    Also, the webGUI is now blank.

    What now?

  • Moderator

    @WourN That’s correct.

  • @Tom-Elliott all right, I ran svn up
    Now I need to run ./ again right?

  • as I said, this is before I update SVN. Will run svn upgrade now

  • @WourN So I don’t understand why you’re still installing -RC-1?

    We’re up to 30.

    If you’re running svn up you should be getting the most current.

  • Version 1.3.0-RC-1
    SVN Revision: 5936

    SVN revision is before I updated SVN though, I have now reverted the server to before it was updated.

  • What RC are you installing? 1.3.0 hasn’t been released yet.