Mulitcast from storage node problem



  • I have been searching (both on the servers and on the web) for an answer to this problem:

    I have a multi serversetup with fog.
    Servers are Ubuntu 10.04
    installed Fog 0.32

    The network is setup in a star topology format. The primary (normal install) fog server is at the root of the network at the district office, and I have 3 other storage groups residing in separate buildings (high school, middle school and elementary school). Each group is only a single computer.

    Initially I had a problem adding the first storage node to Fog but it turned out a password typo. Everything else worked fine.

    Now I can store images on all three servers and uni-cast, memtest, disk wipe… ext which works great.

    Symptom 1. Now however I tried a multicast a computer lab of 30 machines. From the HS storage group. It hung on please wait.
    I found the multicasting wiki which pointed to the two config files. I checked the password and even reset root password to be blank. (it was blank to start with) flushed privileges, restart everything and reboot everything.

    [B]fogNormal[/B] - /opt/fog/log/multicast.log
    [06-29-12 1:53:24 pm] Checking if I am the group manager.
    [06-29-12 1:53:24 pm] * [06-29-12 1:53:24 pm] I am the group manager.
    [06-29-12 1:53:24 pm] | [06-29-12 1:53:24 pm] Task (10) test is new!
    [06-29-12 1:53:24 pm] | [06-29-12 1:53:24 pm] Task (10) test failed to execute, image file not found!
    [B]fogNormal[/B] - /opt/fog/log/fogReplicator.log
    [06-29-12 1:50:41 pm] Checking if I am the group manager.
    [06-29-12 1:50:41 pm] * [06-29-12 1:50:41 pm] I am the group manager.
    [06-29-12 1:50:41 pm] * [06-29-12 1:50:41 pm] Starting Image replication.
    [06-29-12 1:50:41 pm] * [06-29-12 1:50:41 pm] Determining my group ID number.
    [06-29-12 1:50:41 pm] * [06-29-12 1:50:41 pm] Looking up my node ID number
    [06-29-12 1:50:41 pm] * [06-29-12 1:50:41 pm] NODE ID# 1
    [06-29-12 1:50:41 pm] * [06-29-12 1:50:41 pm] We are group ID: #1
    [06-29-12 1:50:41 pm] * [06-29-12 1:50:41 pm] Finding group members.
    [06-29-12 1:50:41 pm] * [06-29-12 1:50:41 pm] I am the only member, no need to copy anything!.

    [B]fogNormal[/B] - /opt/fog/log/fogScheduler.log
    [06-29-12 1:49:38 pm] Checking if I am the group manager.
    [06-29-12 1:49:38 pm] * [06-29-12 1:49:38 pm] I am the group manager.
    [06-29-12 1:49:38 pm] * [06-29-12 1:49:38 pm] No tasks found.

    [B]fogStorage[/B]- /opt/fog/log/ (multicast.log fogReplicator.log, fogScheduler.log)
    Failed to connect to database server, will try again in next iteration.

    So I set the mysql username and password in;
    /opt/fog/service/etc/config.php
    and double checked
    /var/www/fog/commons/config.php
    and reset. So far I tried,
    *FOG_STORAGENODE_MYSQLUSER and password, found under other information
    *root and blank password

    Now this image works file with unicast, but multicast it couldnot find the file.
    It DOES work when the image is located on the normal fog install. The nodes are set as master nodes. It feels like I have tried everything, but Im not sure if I am missing something. Any tips?



  • Hmm Ok what does your multicast.log say for both the master storage node and the main distribution server say. (there are separate logs on all nodes and servers) That might help diagnose,

    oh and did you multicast before in your school? I saw a few places where switches dont support multicast so the packets where not being routed right.



  • Ok, I made the changes to the storage groups and nodes. So now my school storage node is in its own group and is the master of that group. I am getting further in one sense. I am now seeing on the multicast log on the school node where it is trying to kick off the multicast session (I also see the same on the central office server), but I still only get the “please wait” on the workstations trying to image. I even went in and put a maxwait value of 300 in the config.php file and that doesn’t kick it off either. If you come up with anymore suggestions/ideas I would appreciate it. Your last comment at least go me a little further.



  • [quote=“Corey Cochran, post: 4917, member: 1582”]I too am having the same issue trying to multicast from a storage server at a school. I have tried the steps mentioned above and have gained access to the mysql database from the school server and my log entry now says “I don’t appear to be the group manager, I will check back later.” for the multicast log on the school server. Although, when I kick off a multicast image I still get to the screen that says “please wait” and hangs here indefinitely. The multicast log on the main server at the central office reflects that it is trying to kick off the multicast and has the info in the log.

    Any information that you can help lead me in the right direction or something I might be missing?

    Thanks[/quote]

    I wont pretend to be an expert on this yet, but it sounds from that message that the storage node has indeed connected, but I think looking at the wiki it shows the multicast only runs from the ‘master’ storage node. I think that could be where your trouble lies.

    [url]http://www.fogproject.org/wiki/index.php/Managing_FOG#Storage_Management[/url]

    So you have to make sure your groups are setup properly, with a master node in order to work. If you are like us and only have a single node per group then you can go ahead and set that as the group master. That should do the trick, but no matter if you have a single node or a group of nodes, make sure you backup those images. ;)

    Let me know how it goes.

    Oh yeah, you can do this by storage mangement -> all storage nodes -> is master node (check it) read the warning too



  • I too am having the same issue trying to multicast from a storage server at a school. I have tried the steps mentioned above and have gained access to the mysql database from the school server and my log entry now says “I don’t appear to be the group manager, I will check back later.” for the multicast log on the school server. Although, when I kick off a multicast image I still get to the screen that says “please wait” and hangs here indefinitely. The multicast log on the main server at the central office reflects that it is trying to kick off the multicast and has the info in the log.

    Any information that you can help lead me in the right direction or something I might be missing?

    Thanks



  • Fixed :)
    Ok so this is what I did. I have SSH installed on all servers. Remote connecting to any machine.
    I attempted to connect to MySql through the terminal from the HS computer, with the command;
    [CODE]mysql -h [ip of normal install computer] -u root -p[/CODE]
    with a null password, it said access denied.
    I figured the reason is that the install of MySql only accepts local users/computer connections. So the bind has to be setup like the post above, but also the user has to be setup for requests outside localhost.

    I figured this about Friday and was on track to setting it up but messed up somewhere in the root settings so it would only accept root connections from another IP (not local host… woops) therefor it made it difficult to run mysqldump but got it in the end. (but I forgot to back up the images too [url=http://www.freesmileys.org/smileys.php][img]http://www.freesmileys.org/smileys/smiley-angry032.gif[/img][/url])

    Ok so I went to the normal install server and created a new user, then granted privileges to the fog database. I didnot know what privileges the nodes need so I gave a grant all. Though technically insecure… but ah well…
    mysql commands;

    [CODE]mysql> CREATE USER ‘fogRemote’@’%’ IDENTIFIED BY ‘fog’;
    mysql> GRANT ALL ON fog.* TO fogRemote@’%’ IDENTIFIED BY ‘fog’;
    mysql>flush privileges;
    mysql>exit
    sudo /etc/init.d/mysql restart
    [/CODE]

    Now I go download via FTP both the
    /opt/fog/service/etc/config.php
    /var/www/fog/commons/config.php

    and change host/username/pass to:
    [CODE]define( “MYSQL_HOST”, “[ip_of_your_mysql_install(normal fog install)]” );
    define( “MYSQL_DATABASE”, “fog” );
    define( “MYSQL_USERNAME”, “fogRemote” );
    define( “MYSQL_PASSWORD”, “fog” );
    [/CODE]

    and upload (i can directly upload via ftp because I chmod 777 on the config.php
    otherwise would FTP to desktop, then move to folders via SSH.

    Then restart service(s)
    [CODE]sudo /etc/init.d/FOGMulticastManager restart[/CODE]

    I was then able to re-connect to HS computer
    and remotely connect to mysql by;
    [CODE]mysql -h [ip of normal install computer] -u fogRemote -p[/CODE]
    …and it worked!

    Hopefully this will help other people when attempting multicast from storage nodes from fresh updated install with MySql.



  • [quote=“chad-bisd, post: 4509, member: 18”]check your /etc/mysql/my.cnf file, line for Binding Address =

    It should be the real IP of the machine, not 127.0.0.1. If you change this, restart mysql service and try again. By default on Ubuntu 10.04, mysql cannot accept connections from outside hosts.

    This may not solve everything, but it’ll get us moving towards the solution.[/quote]

    Yes that has been set to the IP of the machine,

    Also a port scan shows 3306 is indeed open.


  • Moderator

    check your /etc/mysql/my.cnf file, line for Binding Address =

    It should be the real IP of the machine, not 127.0.0.1. If you change this, restart mysql service and try again. By default on Ubuntu 10.04, mysql cannot accept connections from outside hosts.

    This may not solve everything, but it’ll get us moving towards the solution.


Log in to reply
 

424
Online

39.3k
Users

11.0k
Topics

104.3k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.