PXE Boot HP X2 210



  • Re: PXE Boot HP X2 210 (Hybrid tablet Windows 10 Pro)
    I have a HP X2 210 hybrid tablet with Windows 10 that i want to capture a image of.
    But after setting a capture task it stops at:
    BZimage…ok
    init.xz…ok
    could not boot: no such device.
    could not boot: no such device.
    could not boot: no such device.
    Chainloading failed, hit ‘s’ or the IPXE shell; reboot in 10 seconds

    Also when i try to do a automatic host registration is just goes back to the FOG options screen.
    I have added the machine manually in the FOG web interface

    Fog Version:
    Running Version 1.3.0-RC-25
    SVN Revision: 6020

    Any advice is appreciated.



  • @george1421
    Yes i have just tried that and the result is the same.



  • @x23piracy
    The uefi PXE works since i do get the FOG screen after i network boot.
    I also get DHCP settings applied.
    The problem is that after i try to do anything with FOG it does not work.



  • @Nibor25 said in PXE Boot HP X2 210:

    @x23piracy
    What Bios version is this?
    Mine is F.05 and it does not got the options you are showing in the picture.

    whoops i think i made a little mistake, we have HP x2 1012 devices, i googled your device and its different and it seems hp disabled legacy for this device, bad new world. Sorry for getting the device wrong.

    i found something on the hp forums:

    https://h30434.www3.hp.com/t5/Business-Notebooks/x2-210-PXE-boot/m-p/5522874

    but it’s unsolved 3 people screaming for legacy option.

    I think you need to use UEFI to image this device, there are howtos how to get uefi pxe working, you may need to create a new image you cannot use legacy image while booting uefi.

    Regards X23



  • @x23piracy
    What Bios version is this?
    Mine is F.05 and it does not got the options you are showing in the picture.



  • @Nibor25 said in PXE Boot HP X2 210:

    @x23piracy
    That was the first thing that we have tried. Unfortunately there does not seem to be a option to enable Legacy.
    Could you advice me how to enable legacy boot?
    Thanks in advance,

    Hi, i use it’s usb type c dock to have a wired network connection.
    Goto the BIOS and set the following to legacy:

    alt text

    Regards X23


  • Moderator

    @Nibor25 since this is a USB nic. Have you manually registered a test system and then in the host configuration set the kernel parameter has_usb_nic=1 to see if that helped?

    ref: https://wiki.fogproject.org/wiki/index.php?title=USB_NIC_(usb_network_adapter)



  • @george1421
    We are using the USB network adapter Lenovo Thinkpad Ethernet adapter Model Number PN:RTL8153
    It is in UEFI mode and we have not found a option to enable Legacy. Just the option to disable secure boot.



  • @x23piracy
    That was the first thing that we have tried. Unfortunately there does not seem to be a option to enable Legacy.
    Could you advice me how to enable legacy boot?
    Thanks in advance,



  • Hi, we have the same devices, you need to enable legacy.


  • Moderator

    What network adapter are you using? From the sounds of it iPXE is supporting the network driver (or bzImage would not be transferred), but the FOS engine (customized linux OS) doesn’t have the does…

    What its transferring the images (bzImage and init) but then its reporting chain loading failed no such device still in the iPXE menu.

    On the HP, what mode is it in uefi or legacy (bios) mode? If its in uefi mode, please confirm that secure boot is disabled.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.