Error upgrading from 1.2 to 1.3 rc 25



  • Server
    • FOG Version: 1.20 to 1.3. rc 25
    • OS: centos 6
    Client
    • Service Version:
    • OS:
    Description

    Error during uppgrade

    Here the tail of fog_error_1.3.0-RC-25.log :
    Nouveau mot de passe : Retapez le nouveau mot de passe : Changement de mot de passe pour l’utilisateur fog.
    passwd : mise à jour réussie de tous les jetons d’authentification.
    Arrêt de FOGMulticastManager : [ OK ]
    Arrêt de FOGImageReplicator : [ OK ]
    Arrêt de FOGTaskScheduler : [ OK ]
    Arrêt de mysqld : [ OK ]
    Démarrage de mysqld : [ OK ]
    mysqld (pid 3639) en cours d’exécution…
    Arrêt de httpd : [ OK ]
    Arrêt de php-fpm : [ÉCHOUÉ]
    Generating RSA private key, 4096 bit long modulus
    …++
    …++
    e is 65537 (0x10001)
    You are about to be asked to enter information that will be incorporated
    into your certificate request.
    What you are about to enter is what is called a Distinguished Name or a DN.
    There are quite a few fields but you can leave some blank
    For some fields there will be a default value,
    If you enter ‘.’, the field will be left blank.

    Country Name (2 letter code) [XX]:State or Province Name (full name) []:Locality Name (eg, city) [Default City]:Organization Name (eg, company) [Default Company Ltd]:Organizational Unit Name (eg, section) []:Common Name (eg, your name or your server’s hostname) []:Email Address []:Generating RSA private key, 4096 bit long modulus
    …++
    …++
    e is 65537 (0x10001)
    You are about to be asked to enter information that will be incorporated
    into your certificate request.
    What you are about to enter is what is called a Distinguished Name or a DN.
    There are quite a few fields but you can leave some blank
    For some fields there will be a default value,
    If you enter ‘.’, the field will be left blank.

    Country Name (2 letter code) [XX]:State or Province Name (full name) []:Locality Name (eg, city) [Default City]:Organization Name (eg, company) [Default Company Ltd]:Organizational Unit Name (eg, section) []:Common Name (eg, your name or your server’s hostname) []:Email Address []:
    Please enter the following ‘extra’ attributes
    to be sent with your certificate request
    A challenge password []:An optional company name []:Signature ok
    subject=/CN=192.168.122.3
    Getting CA Private Key
    ln: création d’un lien symbolique « /var/www/html/fog/fog »: Le fichier existe
    Arrêt de httpd : [ OK ]
    Démarrage de httpd : httpd: apr_sockaddr_info_get() failed for fogus-maquette.istic.univ-rennes1.fr
    httpd: Could not reliably determine the server’s fully qualified domain name, using 127.0.0.1 for ServerName
    [ OK ]
    Arrêt de php-fpm : [ÉCHOUÉ]
    Démarrage de php-fpm : [ OK ]
    httpd (pid 4485) en cours d’exécution…
    php-fpm (pid 4530) en cours d’exécution…
    –2016-11-24 10:34:55-- http://192.168.122.3//fog//maintenance/backup_db.php
    Connexion vers 192.168.122.3:80…connecté.
    requête HTTP transmise, en attente de la réponse…500 Internal Server Error
    2016-11-24 10:34:55 ERREUR 500: Internal Server Error.


  • Developer

    Ok, thanks for letting us know. Marking this as solved then.



  • Thank you
    As you told me, I upgraded PHP to 5.6 and it works
    I tried with 26 released


  • Moderator

    You shouldn’t alter the installation files. I have no idea what state they’re in or what they’re actually doing now, making it impossible to assist.

    The only problem you had was that PHP5.3 was installed and that a newer version needed to get installed. The installer has ways of managing that, no need to alter the scripts themselves.

    So, remove your FOG svn folder and pull a fresh version to make sure everything is as it should be.

    Then remove the packages= line from /opt/fog/.fogsettings (otherwise it will continue to select PHP5.3 packages as previously defined by 1.2 installer)

    Remove every trace of PHP 5.3 from your system.

    Run the commands Tom gave.

    Then run the installer.


  • Senior Developer

    Please try:

    wget http://rpms.famillecollet.com/enterprise/remi-release-6.rpm ; sudo rpm -Uvh remi-release-6*.rpm

    Then run:

    yum -y update --enablerepo=remi,remi-php56

    Then rerun the installer.



  • I was to much violent with sed .
    Repaired …
    Now Setting up Apache and PHP files…Failed
    ###########################################

    PHP Failed to install properly

    ###########################################

    Could not find !



  • yum remove php* did not make me have a succes
    So I edited lib/redhat/config.sh, lib/common/functions.sh and lib/redhat/.svn/text-base/config.sh.svn-base to change php to php55w after
    rpm -Uvh https://mirror.webtatic.com/yum/el6/latest.rpm
    yum install yum-plugin-replace
    yum replace php-common --replace-with=php55w-common

    But now I have this error:

    • Setting up fog user…Already setup
    • Setting up fog password…OK
    • Stopping FOGMulticastManager Service…OK
    • Stopping FOGImageReplicator Service…OK
    • Stopping FOGSnapinReplicator Service…OK
    • Stopping FOGScheduler Service…OK
    • Stopping FOGPingHosts Service…OK
    • Setting up and starting MySQL…OK
    • Backing up user reports…Done
    • Stopping web service…Failed!

    Here is the tail of error_logs/fog_error_1.3.0-RC-25.log

    Arrêt de FOGMulticastManager : [ÉCHOUÉ]
    Arrêt de FOGImageReplicator : [ÉCHOUÉ]
    Arrêt de FOGTaskScheduler : [ÉCHOUÉ]
    Arrêt de mysqld : [ OK ]
    Démarrage de mysqld : [ OK ]
    mysqld (pid 6322) en cours d’exécution…
    Arrêt de httpd : [ OK ]
    php55w-fpm: service non reconnu


  • Moderator

    @lebrun78 You will need to remove the packages line from /opt/.fogsettings and remove PHP.

    Something like

    yum remove php*
    


  • other problem, php version seems to not be checked before installation,

    so when I’m connect to http://192.168.122.3/fog/management/ to valid myslq backup and update, I got that:
    “FOG Requires PHP v5.5.0 or higher. You have PHP v5.3.3”



  • Error is in the file /opt/fogproject/packages/web/commons/init.php, no ?


  • Moderator

    @lebrun78 Hi, please do

    rm -rf /var/www/html/fog
    rm -rf /var/www/fog
    

    Then try running the installer again.



  • Hello,

    Here is the apache error:

    [Thu Nov 24 10:34:48 2016] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
    [Thu Nov 24 10:34:48 2016] [notice] Digest: generating secret for digest authentication …
    [Thu Nov 24 10:34:48 2016] [notice] Digest: done
    [Thu Nov 24 10:34:48 2016] [notice] Apache/2.2.15 (Unix) DAV/2 PHP/5.3.3 mod_ssl/2.2.15 OpenSSL/1.0.1e-fips configured – resuming normal operations
    [Thu Nov 24 10:34:55 2016] [error] [client 192.168.122.3] PHP Parse error: syntax error, unexpected ‘&’ in /var/www/html/fog/commons/init.php on line 109
    [Thu Nov 24 10:37:27 2016] [error] [client 192.168.122.1] PHP Parse error: syntax error, unexpected ‘&’ in /var/www/html/fog/commons/init.php on line 109
    [Thu Nov 24 10:37:35 2016] [error] [client 192.168.122.1] PHP Parse error: syntax error, unexpected ‘&’ in /var/www/html/fog/commons/init.php on line 109


  • Moderator

    The apache server returns a 500 error. Can you tail the apache error log? (var/log/httpd/error_log)


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.