TFTP Timeout- Related to vsftd?



  • Hello! I’m excited to get FOG going on our school district server!

    I followed the instructions [URL=‘http://fogproject.org/forum/threads/how-to-install-fog-on-ubuntu.5/’]here[/URL] to initially install on a new/clean Ubuntu 12.04 server with only OpenSSH as a service selected. I then configured SAMBA and installed FOG 0.32. I got the error reported frequently with the TFTP service such as this post [URL=‘http://fogproject.org/forum/threads/a-simple-tftp-cant-connect-question-honest.738/’]here[/URL]. When creating an image I get the message, " [URL=‘http://fogproject.org/forum/threads/a-simple-tftp-cant-connect-question-honest.738/’]U[/URL]nable to start task/Unable to connect to TFTP server."

    I have followed instructions on setting the fog user password and changing the config files with restarting. No go. I decided to wipe the OS and try again. Same problem again.

    I have (possibly) narrowed this down to the vsftpd service. I can connect and perform a GET to the TFTP service, but when I attempt to connect via command-line to FTP, the following message appears:

    [I]500 OOPS Priv_Sock_Get_Result[/I]
    [I]Login Failed.[/I]
    [I]421 Service not available, remote server has closed connection[/I]

    I’ve looked into this error for vsftpd and am not sure how to proceed, but since quite a few have reported this with mixed success I wonder if there is something additional on the install-side we need to do in order to fix this problem? I am rusty with CLI on Linux and would appreciate any help I can get to figure this problem. I’m including the config files here:

    /var/www/fog/commons/config.php:
    [PHP]<?php
    define( “IS_INCLUDED”, true );
    define( “TFTP_HOST”, “10.1.1.30” );
    define( “TFTP_FTP_USERNAME”, “fog” );
    define( “TFTP_FTP_PASSWORD”, “-somethingencrypted-” );
    define( “TFTP_PXE_CONFIG_DIR”, “/tftpboot/pxelinux.cfg/” );
    define( “TFTP_PXE_KERNEL_DIR”, “/tftpboot/fog/kernel/” );
    define( “PXE_KERNEL”, “fog/kernel/bzImage” );
    define( “PXE_KERNEL_RAMDISK”, 127000 );
    define( “USE_SLOPPY_NAME_LOOKUPS”, “1”);
    define( “MEMTEST_KERNEL”, “fog/memtest/memtest” );
    define( “PXE_IMAGE”, “fog/images/init.gz” );
    define( “PXE_IMAGE_DNSADDRESS”, “” );
    define( “STORAGE_HOST”, “10.1.1.30” );
    define( “STORAGE_FTP_USERNAME”, “fog” );
    define( “STORAGE_FTP_PASSWORD”, “-somethingencrypted-” );
    define( “STORAGE_DATADIR”, “/images/” );
    define( “STORAGE_DATADIR_UPLOAD”, “/images/dev/” );
    define( “STORAGE_BANDWIDTHPATH”, “/fog/status/bandwidth.php” );
    define( “CLONEMETHOD”, “ntfsclone” ); // valid values partimage, ntfsclone
    define( “UPLOADRESIZEPCT”, 5 );
    define( “WEB_HOST”, “10.1.1.30” );
    define( “WEB_ROOT”, “/fog/” );
    define( “WOL_HOST”, “10.1.1.30” );
    define( “WOL_PATH”, “/fog/wol/wol.php” );
    define( “WOL_INTERFACE”, “eth0” );
    define( “SNAPINDIR”, “/opt/fog/snapins/” );
    define( “QUEUESIZE”, “10” );
    define( “CHECKIN_TIMEOUT”, 600 );
    define( “MYSQL_HOST”, “localhost” );
    define( “MYSQL_DATABASE”, “fog” );
    define( “MYSQL_USERNAME”, “root” );
    define( “MYSQL_PASSWORD”, “myrealsqlpassword” );
    define( “DB_TYPE”, “mysql” );
    define( “DB_HOST”, MYSQL_HOST );
    define( “DB_NAME”, MYSQL_DATABASE );
    define( “DB_USERNAME”, MYSQL_USERNAME );
    define( “DB_PASSWORD”, MYSQL_PASSWORD );
    define( “DB_PORT”, null );
    define( “USER_MINPASSLENGTH”, 4 );
    define( “USER_VALIDPASSCHARS”, “1234567890ABCDEFGHIJKLMNOPQRSTUVWZXYabcdefghijklmnopqrstuvwxyz_hB()^!” );
    define( “NFS_ETH_MONITOR”, “eth0” );
    define(“UDPCAST_INTERFACE”,“eth0”);
    define(“UDPCAST_STARTINGPORT”, 63100 );
    // Must be an even number! recommended between 49152 to 65535
    define(“FOG_MULTICAST_MAX_SESSIONS”, 64 );
    define( “FOG_JPGRAPH_VERSION”, “2.3” );
    define( “FOG_REPORT_DIR”, “./reports/” );
    define( “FOG_THEME”, “blackeye/blackeye.css” );
    define( “FOG_UPLOADIGNOREPAGEHIBER”, “1” );
    define( “FOG_VERSION”, “0.32” );
    define( “FOG_SCHEMA”, 23);
    DEFINE(‘BASEPATH’, rtrim($_SERVER[‘DOCUMENT_ROOT’], ‘/’) . rtrim(WEB_ROOT, ‘/’));
    ?> [/PHP]

    /opt/fog/service/etc/config.php:
    [PHP]<?php
    define( “UPDSENDERPATH”, “/usr/local/sbin/udp-sender” );
    define( “MULTICASTLOGPATH”, “/opt/fog/log/multicast.log” );
    define( “MULTICASTDEVICEOUTPUT”, “/dev/tty2” );
    define( “MULTICASTSLEEPTIME”, 10 );
    define( “MULTICASTINTERFACE”, “eth0” );
    define( “UDPSENDER_MAXWAIT”, null );

    define( “MYSQL_HOST”, “” );
    define( “MYSQL_DATABASE”, “fog” );
    define( “MYSQL_USERNAME”, “” );
    define( “MYSQL_PASSWORD”, “6^3#Kids” );

    define( “LOGMAXSIZE”, “1000000” );

    define( “REPLICATORLOGPATH”, “/opt/fog/log/fogreplicator.log” );
    define( “REPLICATORDEVICEOUTPUT”, “/dev/tty3” );
    define( “REPLICATORSLEEPTIME”, 600 );
    define( “REPLICATORIFCONFIG”, “/sbin/ifconfig” );

    define( “SCHEDULERLOGPATH”, “/opt/fog/log/fogscheduler.log” );
    define( “SCHEDULERDEVICEOUTPUT”, “/dev/tty4” );
    define( “SCHEDULERWEBROOT”, “/var/www/fog” );
    define( “SCHEDULERSLEEPTIME”, 60 );
    ?>
    [/PHP]

    Before I go further I was wondering if I might be on the right path or not. I’m not quite sure how to make sure another FTP app is/is not conflicting or what other things I should look at. Thanks for any help you can provide!



  • How do you go about changing the host name and setting a reservation and alias?



  • I figured out.our problem. It turns out that the older fog server had the name in the dhcp 066 setting. I named the new server the same name but with a 2. That’s why it wouldn’t communicate. As soon as I changed the host name nd set a reservation and alias it worked great



  • I ended up backing out and using an older rev of Ubuntu and it worked perfectly at capturing and pushing a test image! The problem appears to be with FTP and not Fog. I couldn’t get FTP to work properly before installing Fog and continued to get the error below regardless of what I configured or the user I logged in as.
    [I]500 OOPS Priv_Sock_Get_Result[/I]
    [I]Login Failed.[/I]
    [I]421 Service not available, remote server has closed connection[/I]
    [I][/I]



  • I am having the same problem. I am using Ubuntu 10.04 and 0.32 FOG. I have rebuilt the server and reinstalled FOG three times but never can get it to work. Well, there was one time but the HD size was too small… as soon as i made the HD bigger it had the tftp open timeout problem. None of my clients can see the server when trying to PXE boot… HELP!!!


  • Moderator

    did you check to make sure the ftp service is running? You can login to the FTP service using the information at:
    [CODE]define( “STORAGE_FTP_USERNAME”, “fog” );
    define( “STORAGE_FTP_PASSWORD”, “-somethingencrypted-” );[/CODE]

    Also, there are some minor issues with Fog 0.32 and Ubuntu Server 12.04 LTS. Just minor kinks being worked out. I continue to suggest those new to fog stick with Fog 0.32 on Ubuntu Server 10.04 LTS. There is better support within the Fog forums due to its age and the number of folks currently running that combo of OS/Fog.



  • When I FTP into an admin account, I get the same error. I thought it was a permissions problem, but not sure. I uninstalled and reinstalled vsftp and still no success. Would be very appreciative of any thoughts or ideas!


Log in to reply
 

404
Online

39.3k
Users

11.0k
Topics

104.5k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.