Problem on HP ProBook 650g2



  • Server
    • FOG Version: 1.3.0-RC-23 (6017)
    • OS: Linux Debian stable
    Client
    Description

    I use my own dhcp server and tftp server (192.168.39.247)

    My DHCP server configuration
    subnet 192.168.39.0 netmask 255.255.255.0 { # Sous-reseau et masque
    range 192.168.39.36 192.168.39.230; # Plage d’addresses
    …/…

    next-server 192.168.39.247;
    filename “pxelinux.0”;

    My TFTP server configuration (192.168.39.243 is the ip of the fog server)
    LABEL FOG_ETUDIANTS
    MENU LABEL Clonage de postes avec FOG pour les postes ETUDIANTS
    KERNEL fog/ipxe.krn dhcp && chain http://192.168.39.243/fog/service/ipxe/boot.php?mac=${net0/mac}

    During boot i’ve got this error message
    Warning using legacy NIC wrapper on 00:00:00:00:00:00
    Configuring NET0 00:00:00:00:00:00
    error 040ee119
    Configuring NET1 98:e7:f4:e8:2b:bd

    I launch full registeration and inventory everything works fine but at next reboot :
    Host is not registered.
    Does someone could help me ?



  • @x23piracy said in Problem on HP ProBook 650g2:
    Then have you got problem with computer with Realtek RTL8168D/8111D NIC (if you have some)
    Thanks for your answer



  • @plegrand said in Problem on HP ProBook 650g2:

    Are you using ipxe.pxe or undionly.kpxe ?
    If you use “undionly.kpxe”, have you got problem with computer with Realtek RTL8168D/8111D NIC

    Thanks for your answer

    lets have a look:

    alt text

    Regards X23



  • @x23piracy
    "we have a lot of this probook’s 650 G2 and they are working fine for me."

    Just to be sure :

    you havent this message :
    Warning using legacy NIC wrapper on 00:00:00:00:00:00

    Are you using ipxe.pxe or undionly.kpxe ?
    If you use “undionly.kpxe”, have you got problem with computer with Realtek RTL8168D/8111D NIC

    Thanks for your answer


  • Senior Developer

    @plegrand The first nic weirdness is expected as I said. Using ipxe.pxe should work, and as you and I both suspect I still think it’s the bluetooth part. Unfortunately I don’t think it’s something your or I can fix. As long as all still ‘works’ after that point, you should be fine though.



  • @Tom-Elliott i 'm making a lot of tests with my new configuration (ipxe) and it seems everything works fine except : Warning using legacy NIC wrapper on 00:00:00:00:00:00 message.
    Then everything it’s ok !!

    Just for information here is my new menu for ipxe (default.ipxe)

    #!ipxe
    # Variables utilisables : http://ipxe.org/cfg
    # Commandes utilisables : http://ipxe.org/cmd
    
    # --------------------------- VARIABLES ----------------------------------------
    # TimeOut de 5 secondes
    set TimeOut 5000
    
    set fog-proto http
    set fog-ip 192.168.39.243
    set fog-webroot fog
    set fog-url ${fog-proto}://${fog-ip}/${fog-webroot}
    
    set tftp-proto tftp
    set tftp-ip 192.168.39.247
    set tftp-url ${tftp-proto}://${tftp-ip}
    set ghost-directory ghost
    set memdisk-bin memdisk
    # ------------------------------------------------------------------------------
    
    # Test du processeur : si ext 29 alors 64 bits sinon 32 bits
    # && : Si Oui 
    # || : Si Non
    cpuid --ext 29 && set arch x86_64 || set arch i386
    
    # Image de fond
    console --picture http://192.168.39.243/fog/service/ipxe/bg.png --left 100 --right 8
    
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    param platform ${platform}
    param product ${product}
    param manufacturer ${product}
    param ipxever ${version}
    param filename ${filename}
    # S'il existe une seconde carte réseau alors le paramètre mac1 correspondra à son adresse mac. Sinon branchement sur MENU.
    # S'il existe une troisième carte réseau alors le paramètre mac2 correspondra à son adresse mac. Sinon branchement sur MENU.
    isset ${net1/mac} && param mac1 ${net1/mac} || goto MENU
    isset ${net2/mac} && param mac2 ${net2/mac} || goto MENU
    
    :MENU
    menu
    item Local      Boot local
    item Fog        Fog
    # item HostInfo   Informations sur cette machine
    item Shell      IPXE shell
    item Ghost      Ghost Drivers Universels
    choose --default Local --timeout ${TimeOut} target && goto ${target}
    
    :Local
    sanboot --no-describe --drive 0x80 || 
    prompt
    goto MENU
    
    :Fog
    chain ${fog-url}/service/ipxe/boot.php##params ||
    prompt
    goto MENU
     
    :HostInfo
    echo This computer : ||
    echo MAC address....${net0/mac} ||
    echo MAC address....${net1/mac} ||
    echo MAC address....${net2/mac} ||
    echo IP address.....${ip} ||
    echo Netmask........${netmask} ||
    echo Serial.........${serial} ||
    echo Asset number...${asset} ||
    echo Manufacturer...${manufacturer} ||
    echo Product........${product} ||
    echo BIOS platform..${platform} ||
    echo ||
    echo press any key to return to Menu ||
    prompt
    goto MENU
    
    :Shell
    shell ||
    goto MENU
    
    :Ghost
    kernel ${tftp-url}/${memdisk-bin} keeppxe floppy
    initrd ${tftp-url}/${ghost-directory}/universels.img
    boot memdisk
    prompt
    goto MENU
    
    autoboot
    

    Tanks again


  • Senior Developer

    @plegrand I can solve it, just wanted to make sure it was “okay” to do so.



  • @Tom-Elliott
    Hello
    do you want i solve this thread ?


  • Senior Developer

    I think so too, but yours is definitely not the first of this issue being reported. When I get home tonight (I’m on EST) i will test an upload just to ensure all is well. If I find any issues with the init’s I’ll try fixing and posting info on them. Thanks for your time too.



  • @Tom-Elliott
    i think also is the bluetooth adapter

    The thread is solved for me except "Fatal Error, unable to find size data out on"
    But i think this problem come from the original partitionning (new HP computer with a lot of partition)
    I have to reinstall it with the good number of partition.
    As we saw that before i think it will solve the problem ?

    Big, enormous thanks again for Fog and your precious help .


  • Senior Developer

    @plegrand Would it be safe, for now, to solve the thread?

    I ran into a similar issue with HP ProBook 645 G2 and the fix for us was to use the ipxe.pxe file as well.

    I also saw the “net 0 [00:00:00:00:00:00]” messages, but I think this is the nic’s Bluetooth adapter only translated off the nic with an invalid mac address as there’s nothing for it to connect to.



  • @Tom-Elliott
    For the moment here is the tests i made :

    I use ipxe.pxe

    Then for the “ProBook” Computer i always have this message :

    Warning using legacy NIC wrapper on 00:00:00:00:00:00
    Configuring NET0 00:00:00:00:00:00
    error 040ee119
    Configuring NET1 98:e7:f4:e8:2b:bd
    ...
    

    But the computer is well registered, than i can say that it works

    For the computers with realtek nic it boot fine also.

    Then i keep use ipxe.pxe for the moment and not “undionly.kpxe” (problem with realtek nic)

    I continue my tests.
    thanks again for your help


  • Senior Developer

    @plegrand said in Problem on HP ProBook 650g2:

    Fatal Error, unable to find size data out on

    I’m not going to spell out everything on the file extensions, there’s a wiki page for that here: https://wiki.fogproject.org/wiki/index.php?title=IPXE#What_are_the_differences_between_the_different_PXE_files.3F

    As far as I understand it, the iPXE files already do what your pxelinux.0 default file is doing. It’s just using a different mechanism to provide (more or less) the same level of functionality.

    I’d recommend starting with the ipxe.pxe, but if all of your devices (beyond these systems) are having issues, I’d recommend trying the undionly.kkpxe file. This doesn’t mean your ProBooks will continue to work, but this can be remediated using DHCP user/vendor classes. You can direct systems at which file to use (this works with any file for that matter.)



  • @Tom-Elliott
    Hello Tom, now this computer (HP ProBook 650g2) boot fine and is well registered, but all the others olds computers, which booted fine before, hang now on :

    ipxe initialising devices...
    

    For the moment, computer having this problem has same NIC :
    Carte réseau Realtek RTL8168D/8111D Family PCI-E Gigabit Ethernet (NDIS 6.20)
    As i’m very new to “ipxe”, could you tell me what is the best to use : undionly.kpxe or ipxe.kpxe?
    If i understand :
    undionly.kpxe is universal driver
    ipxe.kpxe contain a lot of nic drivers
    The 2 uses the default.ipxe config file ?
    What is the difference between ipxe.pxe, ipxe.kpxe, ipxe.kkpxe?

    On the probook the only problem is on capture task :

    An error has been detected
    (ShrinkPartition)
    Args passed : /dev/sda2 /images/98e7f4e82bbd/d1.original.fstypes :4:1
    Fatal Error, unable to find size data out on  /dev/sda2. Cmd: ntfsresize -f -i -v -P /dev/sda2
    

    But i think the problem come from the original partitionning.

    The last question is : before i used this kind of configuration file for pxelinux.0 :

    DEFAULT vesamenu.c32
    KBDMAP fr.kbd
     MENU BACKGROUND splash.jpg
     menu color title 1;37;40      #ffffffff #00000000 std
     menu color timeout_msg 37;40  #80ffffff #00000000 std
     menu color timeout 1;31;40    #ffff0000 #00000000 std
     menu color border 30;44 #00000000 #00000000 none
    
    TIMEOUT 300
    ALLOWOPTIONS 0
    PROMPT 0
    
    MENU TITLE MENU
    
    LABEL BootNormal
    MENU LABEL Boot local
    MENU DEFAULT
    COM32 chain.c32
    APPEND hd0
    TEXT HELP
      Boot sur le disque local.
     Valider pour ne pas attendre 30 secondes.
    ENDTEXT
    
    LABEL Drivers_Universels
    MENU LABEL Drivers Universels
    KERNEL memdisk
    APPEND keeppxe floppy initrd=ghost/universels.img
    
    LABEL FOG_ETUDIANTS
    MENU LABEL Clonage de postes avec FOG pour les postes ETUDIANTS
    KERNEL fog/ipxe.krn dhcp && chain http://192.168.39.243/fog/service/ipxe/boot.php?mac=${net0/mac}
    

    is there a way to configure default.ipxe to make the same ?

    thanks again for your help



  • just to be said, we have a lot of this probook’s 650 G2 and they are working fine for me.


  • Senior Developer

    @plegrand The .krn shouldn’t matter as much. As long as you can get the default.ipxe file of the main server to point at the fog server (which you showed you could using the default.ipxe properly) you should be fine. Using the pxelinux.0 will work, as you see, but it’s hit or miss on when it will break things (as far as I’ve seen at least).

    So using the undionly.kpxe file is working for you (the host shows up as registered now?)



  • @Tom-Elliott
    then :

    copy of undionly.kpxe from fog server to tftp server :
    scp /tftpboot/undionly.kpxe 192.168.151.247:/var/lib/tftpboot/

    Change of dhcpd.conf configuration :
    next-server 192.168.39.247;
    filename “undionly.kpxe”;

    i test

    I had to copy also default.ipxe on my tftp server
    scp /tftpboot/default.ipxe 192.168.151.247:/var/lib/tftpboot/

    It seems that it boot fine with fog

    then here is my differents configurations :
    dhcpd.conf of my own dhcp server:

    subnet 192.168.39.0 netmask 255.255.255.0 {
     range 192.168.39.36 192.168.39.230;
     option subnet-mask 255.255.255.0; 
     option broadcast-address 192.168.39.255; 
     option routers 192.168.39.254;
     option domain-name-servers 192.168.39.253;
     option netbios-name-servers 192.168.39.237;
    .../...
     next-server 192.168.39.247;
     filename "undionly.kpxe";
    }
    

    configuration of my own tftp server

    LABEL FOG_ETUDIANTS
    	MENU LABEL Clonage de postes avec FOG pour les postes ETUDIANTS
    	KERNEL fog/ipxe.krn dhcp && chain http://192.168.39.243/fog/service/ipxe/boot.php?mac=${net0/mac}
    

    may be i could copy also an up to date ipxe.krn file ?

    i test capture task


  • Senior Developer

    @plegrand Yes, wherever your TFTP server is, whatever it’s told to look at use the tftp files on the fog server as a guide (if needed).



  • @Tom-Elliott
    you mean on my dhcp server configurationi change pxelinux.0 by undionly.kpxe ?
    then this file has to exist on my dhcp server ? i have to copy it ?


  • Senior Developer

    @plegrand Any way you could use the undionly.kpxe? From the sounds of things it’s not finding the right mac address. I don’t know how the system is seeing things, but it’s almost like it’s not redirecting to the right FOG server. (at least as far as I can tell).


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.