FOG screen appears and disappears



  • I’ve looked through the forum for an answer and haven’t found it. I installed a new FOG server, first on Ubuntu desktop 12.04 and then wiped that out and went to 10.04, using FOG 0.32 both times. Same problem each time. I’m using a Dell Optiplex GX520 to PXE boot to the server and it has “missing parameter” errors flying by, followed by the FOG graphical screen for one second. Then it disappears and it says the boot failed. When I press F1 to try again, it says “!PXE Structure was not found in UNDI driver code segment” and it still won’t boot. It has Windows XP on the hard drive and I updated the BIOS. I also updated the kernel to 3.3.3.

    I’ve tried changing the permissions to vesamenu.c32, pxelinux.0 and chain.c32 as it said in one post. No change in the problem. I’ve tried it on and off our network. No change. I was able to get the TFTP server to respond to a DOS command when it was using 12.04, but now that I changed to 10.04 the same command doesn’t work. I also tried changing the fog user password from a very long sequence of numbers and letters to “password” in two places (TFTP_FTP server password and storage management password). No change in the problem, so I changed it back.

    Does anyone have any ideas before I go all goofy on this thing and make juice?:rolleyes:


  • Moderator

    You can also just push the arrow up or down key and it will stop the timer and give you all day long to read the menu. I set mine short so the end users are not slowed down too much when booting, and to keep the students from trying to mess with the fog menu.



  • As an FYI you can go into your default.cfg file on the fog server and adjust the timeout on the menu as well. I have mine set to 30 seconds.



  • I would like to sincerely thank those who bothered to reply to my problem. I figured it out and I think whoever made the FOG PXE screen default to 3 seconds needs to be horsewhipped. Three seconds is not long enough to read the instructions! PRESS THE SPACE BAR is what I needed to do when the FOG screen appeared. Where in your setup instructions do you say that? It needs to be added. We didn’t all go to the Evelyn Woods Speed Reading Course! Why would you leave out such an important step? Thank you for wasting my time! :(



  • I checked and the drive is SATA 0 in the SX520 and the 745 and there is no socket for a second drive in the SX520.

    Pea soup=fog (not eating the sea poop):)



  • Seems weird your 745 is doing that. I have the same setup (10.04 and fog 0.32) and got my 745s re-imaged without any issues. I do get it on my 990s.

    Another user suggested that the hard drive might be set up for channel 1 as opposed to 0 in the bios/physical cabling. Food for thought anyhow. Don’t eat the sea poop, albeit enticing. =p



  • Further adventures… I found where to modify for boot looping and chainloading, and I used Syslinux 4.05 since I already had it downloaded. I replaced the three files and modified the default file in pxelinux.cfg for the graphical menu and now I still have the same problems of missing parameter messages and a FOG screen that appears and disappears, but the client computer goes into XP instead of failing the PXE boot and stopping for F1 or F2. Any more ideas? Instead of getting pea soup, I’m getting sea poop.



  • Thanks, Chad-bisd, for your reply.

    I tried two other Dell machines (we are a Dell shop and I don’t have anything else to use), an Optiplex 745 and an Optiplex 320 and they both did the same as the GX520. The missing parameter messages fly by and the FOG menu appears, but only for a second and then it quits. If FOG won’t work on these machines, then it’s useless to me. They all seem to have a Broadcomm ethernet adapter.

    Where do I modify to support chainloading? What is the procedure? I searched on that and didn’t find out how to modify it. I did see something about modifying the /tftpboot/pxelinux.cfg/default file, but that didn’t fix anything, nor did replacing the chain.c32 pxelinux.0 and vesamenu.c32 files from Syslinux 4.05. That totally disabled the DHCP and I had to reinstall FOG to get it back. I am a total newbie at FOG and Linux, but I can read and follow instructions!:)


  • Moderator

    Have you checked any other clients for the ability to PXE boot or are you stuck with only GX520’s?

    Have you already modified your Fog 0.32 on Ubuntu 10.04 to support chainloading?


Log in to reply
 

364
Online

38976
Users

10712
Topics

101675
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.