Storage Node unable to register host



  • Server
    • FOG Version: 1.3.0-RC-14
    • OS: Kubuntu 16.04
    Client
    • Service Version: N/A
    • OS:
    Description

    I am getting an error unable to register host (/bin/fog.man.reg) when trying to register any host on new Storage Node. The only issue I see right away is that tftp and http show my master’s IP instead of the node. These computers are in separate offices connected with a VPN. I am able to log in to the master with no issue.


  • Moderator

    We have had people with dual-homed clients have issues prior and those were not resolved.

    I think kernel arguments for network address can be passed and inits then look for that network and any interfaces without it be shut down. I can mess with this maybe Friday or sunday.


  • Senior Developer

    @FallingWax To image clients, the server, as well as nodes, have to be able to communicate properly.

    A client that’s trying to perform some imaging task on 192.168.25 would not be able to image if the server or node is server on 192.168.0 because the subnets cannot cross communicate.



  • @Tom-Elliott that maybe the issue is that it’s not seeing the master properly. I have two NICs on each machine. 1 is LAN access to communicate and the other for local dhcp to image clients respectively. LAN IP on master is 192.168.0.194 and LAN on mode is 192.168.5.135. The nics controlling DHCP are 192.168.25.106 master and node is 192.168.25.105. In /opt/fog/.fogsettings I am using the 25.x ips. Do I have that wrong?


  • Moderator

    said in Storage Node unable to register host:

    The only issue I see right away is that tftp and http show my master’s IP instead of the node.

    The address used to get the specified boot file via tftp is totally dependent on your DHCP settings for the remote site.


  • Senior Developer

    I don’t understand. When you register, it’s not registering to a node, it’s registering to the Master Server.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.