Debugging user tracker



  • I have about 215 computers, running the same Windows 7 Enterprise based image. They are being used by hundreds of students on a daily basis. However, about half of the hosts have no login history in the FOG database. Only 6 hosts report a login in the past 24 hours. The others show login times of more than a month ago (when they were running an older image, with the legacy FOG client).

    Do you have advice on how I could debug this?

    Sorry for the vague question. I’ll gladly provide more details, if I know what to look for.



  • @Wayne-Workman That worked! Thanks!


  • Moderator

    @dolf That probably means you should reset the encryption for all hosts, as I think this is done for you when you image a host.



  • I updated FOG to RC15. Now the FOG clients do update themselves to 0.11.5, but only if I re-deploy the host (using the same image, not a new one).


  • Senior Developer

    @dolf Monday probably but auto update only happens if there’s a new version of the client to update too. So if your image has version 0.11.2, when the client checks in it should update to 0.11.5. I’m thinking the user tracking issue was from server side though, and I believe it is fixed now for RC 15.



  • Thank you. I’ll check the logs when I’m on site on Monday.

    I saw some chatter on the forums about the fog client not updating,so I ask: In order to get the FOG client that contains the fix you mentioned, will it be sufficient to update the FOG server to trunk at this stage?


  • Senior Developer

    I believe I found why this wasn’t happening though more info would be helpful.

    I think the issue was it was requiring a date option to be passed. This would be all well and good for systems who didn’t send the tracking info until later on, explaining why you saw me entries but not all, but I don’t know the date is sent for every insert. Either way I still believe this o be fixed.


  • Moderator

    For issues involving the fog client, always always start with the fog log on an affected host. c:\fog.log

    Please post the last few pages of the log here and we will go from there.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.