Multicast clients fail to check in



  • Server
    • FOG Version: 1.3.0-RC-14
    • OS: Ubuntu 16.04 LTS
    Client
    • Service Version:
    • OS: Windows 7 - 64bit
    Description

    Newly built fog server on isolated network works great capturing and deploying images to individual computers, but I can’t get a multicast session to work. Starting a multicast task from Group Management, no clients are able to check in and give the error: Invalid Multicast Session.

    Going through the troubleshooting steps here, the client identifies the Udp-sender correctly and but the server never sees a client connect.

    Server and client are connected through an unmanaged gigabit switch. I even replaced the switch just to make sure it wasn’t an environment problem. Any ideas?


  • Senior Developer

    @bastienbalaud RC 15 hasn’t been released yet, so are you running the “working-RC-15” branch? Images being associated is not the same as the image “existing” on the node or nodes within your environment.



  • I’ve tried this morning with clearly install of RC15. The problem persist. I’ve checked if the image was correctly associated with the host. I’ve the same log file for Multicast log and the client return the same error.


  • Senior Developer

    So initially I was seeing the same issue just on a whim to test. My issue was as I suspected earlier (that the image didn’t exist on any node that was defined.)

    After looking over, I also validated the Group tasking creation issue, and a potential, but similar, issue hidden within the host tasking creation as well.

    Essentially, host image checking should not have been limited to a single node/group (unless location is defining them for the host). Groups now have a similar check but it removes the hosts that have no images assigned (or images that don’t exist everywhere) and still goes on to continue (unless the images of all hosts don’t exist anywhere).

    Hopefully this helps people see the err of the ways sometimes. Basically to start troubleshooting.


  • Senior Developer

    @kiiile I believe this is fixed for working-RC-15 then. If you would like to give it a shot to see if it work’s please hit me up in the “chat” bubble as I don’t want everybody running over to working-RC-15, just those with special cases such as this. I need to see if thigns in 15 will do better than they had been for 14 and I need that to be very controlled.



  • @Tom-Elliott Only one storage node hosted on the server itself. I captured an image successfully, deployed that image across 4 computers to test individually (and with concurrent individual sessions just to see if it could be done since I’m learning). Everything looked good there. Just multicast that doesn’t seem to be kicking off correctly.

    If groups are having problems starting imaging tasks is there a better way to start a multicast that I’m not aware of?



  • I have the same issue when I deploy image on multicast. The server run under newly installed Debian 8 up to date and FOG 1.3.0-RC-14. The multicast log file is in same state than @kiiile. I have try with 2 node and with only one. The client give the error : “Invalid Multicast Session” in the both case.


  • Senior Developer

    Is there more than one node? As this is a newly installed system, did you capture an image first? Groups don’t have the same checks yet for imaging tasks and as such could present the symptoms you’re describing. (Nothing starting per logs, but generalized tasking created and no multicast task in active state.)


  • Moderator

    @kiiile When I multicast, I normally do Group Management -> Click group -> Basic tasks -> Deploy Multicast. But I would think the two do the same.

    Also, look through this and try the troubleshooting steps. I feel the troubleshooting in this article is more simple to follow, and there are more things to try that may reveal a problem. https://wiki.fogproject.org/wiki/index.php?title=Troubleshoot_Downloading_-_Multicast



  • @Wayne-Workman There’s nothing useful in it. I just started a new multicast task (Group Management > List All Groups>GoTo Basic Tasks>Multi-Cast>Schedule Instant Deployment selected>Create Multi-Cast Taks for GroupName) but the logs report…

    [10-19-16 11:09:40 pm] * No tasks found!
    [10-19-16 11:09:50 pm] * No tasks found!
    [10-19-16 11:10:00 pm] * No tasks found!
    [10-19-16 11:10:11 pm] * No tasks found!
    [10-19-16 11:10:21 pm] * No tasks found!
    [10-19-16 11:10:31 pm] * No tasks found!
    [10-19-16 11:10:41 pm] * No tasks found!
    [10-19-16 11:10:51 pm] * No tasks found!
    [10-19-16 11:11:01 pm] * No tasks found!
    [10-19-16 11:11:11 pm] * No tasks found!
    [10-19-16 11:11:21 pm] * No tasks found!
    [10-19-16 11:11:31 pm] * No tasks found!
    [10-19-16 11:11:41 pm] * No tasks found!
    [10-19-16 11:11:51 pm] * No tasks found!

    When you look at Active Tasks it shows all three hosts from the group with what looks like a paused symbol in the Status Column. When you look at the Active Multicast Tasks though, there’s nothing there. Am I not starting this right?


  • Moderator

    Can you give us the multicast log? Try to do a multicast as you described, and imediately after the failure go here: Web Interface - > FOG Configuration -> Log Viewer -> Multicast Copy/past as much as you can. Be aware of the timestamps in the log, entries from yesterday don’t help us.


Log in to reply
 

329
Online

38729
Users

10555
Topics

99939
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.