FOG Imaging Log Empty?



  • Server
    • FOG Version: SVN Revision 5773
    • OS: Ubuntu 14.04
    Client
    • Service Version:
    • OS:
    Description

    I’m trying to pull up some reports of imaging that was conducted back in August to see what the timeframes were, in order to make comparisons with recent network upgrades that occurred - the purpose is to help show that network upgrades have been valuable in increasing efficiency in PC deployment for our organization. But when I log into FOG and go to Report Management -> Imaging Log, It allows me to select a Start Date as far back as 11-12-2015 and an End Date of today. I can select any date range, and each one gives me "No results found."
    We upgraded to this SVN revision back in June. It was working prior to that upgrade. Am I doing something wrong, or is there a problem I need to fix to get reporting running again?


  • Senior Developer

    The bug is now fixed in working-RC-15 branch.



  • @Wayne-Workman Thank you for reporting the bug. I was able to find the logs I needed using the SQL commands you provided. Thanks a ton! Hopefully the bug gets resolved soon. :)



  • @kenneth.sisco I’ve also confirmed this issue as a bug, because I have the same problem when I tried to see the imaging report. https://forums.fogproject.org/topic/8798/imaging-log-not-displaying-logs

    The below commands should get you by for now though.



  • @kenneth.sisco Via CLI, you can look at the raw data and see what’s there.

    To open the db via CLI:
    mysql -D fog

    To close when done:
    quit

    The table you’re interested in is called imagingLog and you can get it’s description with:
    describe imagingLog;

    You can select all data in it with:
    select * from imagingLog;

    You can sort by date of deployment ascending (asc) or descending (desc) and limit the number of rows returned like:
    select * from imagingLog order by ilStartTime asc LIMIT 20;



  • @Wayne-Workman Yes - these were all from Multicast tasks, which require registration in order to create proper groups, if I recall correctly.



  • Were these image deployments to registered machines? FOG only cares about registered machines. If they weren’t registered, there would be no log of the deployments.

    If they were registered, likely the data is somewhere. Either in the DB but not displaying, or in the automatic backup that the installer made in June.


 

500
Online

41.6k
Users

12.1k
Topics

114.3k
Posts