VirtualBox and no Ethernet



  • Hey,

    I know this might be more of a question for the VirtualBox (VB) commmunity, but it’s specific to FOG.

    I’ve a FOG server running on VB, with a proxy DHCP done with dnsmasq. I then have another VM running on the same machine that I would like to use for testing.
    When I’m connected to a router with an ethernet cable, I can just set both VMs to “Bridged Adapter” and point to the ethernet. This all works fine, and I’ve tested imaging with this.

    Now the problem is when I don’t have access to a router, and I want to continue testing. At this point I only have wireless access to the internet. I can’t seemed to find any combination of settings that allow the VMs to speak together like they are on a normal network. Do anyone have any insight into making this work?


  • Moderator

    @tokejepsen Cool. Thanks for posting the video, I’m sure it’ll help people for a long time in the future.



  • Thanks Wayne, that gave me the missing piece :)

    Turns out I can just use “Host-only Adapter”, and configure the host only to emulate the existing gateway and ip range I’ve set for the ethernet conection. Now I can leave the fog server alone, and just adjust the VirtualBox network connection.

    This was a good little insight video;



  • The FOG server is running Kubuntu 16.04.


  • Moderator

    They are probably simply missing DHCP.

    You can manually setup DHCP on the fog server and turn it on when you need it, and turn off dnsmasq. When you’re connected to a router, you’d turn off DHCP and then turn back on dnsmasq.

    It’s trivial to turn these services off and on, what OS is your FOG server running on?

    I assume it’s just these two VMs missing DHCP, but we do need to figure out exactly what the problem is.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.