AHCI boot iso problems



  • Server
    • FOG Version: 1.2.0
    • OS: ubuntu
    Client
    • Service Version:
    • OS:
    Description


  • @george1421 ,
    Hi,
    with Intel I5/I7 processor the system start correct,
    j1900 e3826 reboot (it’s not a fog problem but ACHI driver installed ).


  • Moderator

    @zingaro said in AHCI boot iso problems:

    I have problems with only winpe.iso ( standard winpe win7 and winpe 8 32 and 64 bit )

    Where did you get this ISOs from? Did you include any drivers in the WinPE images? To me this sounds like a lack of drivers for the ahci mode. I can say that the WinPE 3.0 and 4.0 should natively support ACHI mode unless you have abnormal hardware. Either way you should include / inject the proper drivers for your hardware into the WIM file with DISM.


  • Moderator

    @zingaro said in AHCI boot iso problems:

    I finish two tests with two different PC Intel E3826 and J1900

    AFAIK, these are processors (CPU chips) not computers. What computers are you having problems with?



  • I have problems with only winpe.iso ( standard winpe win7 and winpe 8 32 and 64 bit )



  • Hi,
    I finish two tests with two different PC Intel E3826 and J1900
    with first memdisk start but the system not recognize response at " press any key to start DVD ",
    the second system reboot when windows logo appears…



  • @zingaro and non of this entrys boot propperly also on different computers?

    Regards X23



  • :MENU
    menu
    item --gap – ---------------- iPXE boot menu ----------------
    item minipart Partition Manager
    item memtest6 MemTEST 6.0
    item ghostpe WinPE Shell
    item winpetest WinPE test
    item winpe64 WinPE X64 Shell
    item easusbs Easus Backup Server
    item easuspm Easus Partition Manager
    item acronis Acronis True Image2016
    item winpe8 Windows 8.1 PE
    item acronis2 Acronis TI2013
    item clonezilla Clonezilla
    item add12 Acronis Disk Director
    item aoipart AOIAPartition.
    item pccheck PC CHECK
    item biosupdate Update BIOS UTILITY
    item msdos7 MS-DOS 7.1
    item hiresboot Hires BootCD
    item ultimateboot Ultimate Boot CD
    item testusb USB BOOT ONLY
    item rimage R-IMAGE
    item hostinfo Host Information
    item shell ipxe shell
    item return return to previous menu
    choose --default return --timeout 5000 target && goto ${target}

    :powermax
    initrd http://${fog-ip}/${fog-webroot}/images/powermax.iso
    chain memdisk iso raw ||
    goto MENU

    :minipart
    initrd http://${fog-ip}/${fog-webroot}/images/pwfree.iso
    chain memdisk iso raw ||
    goto MENU

    :memtest6
    kernel memdisk iso raw
    initrd http://${fog-ip}/${fog-webroot}/images/Memtest6.iso
    boot ||
    goto MENU

    :ghostpe
    sanboot http://${fog-ip}/${fog-webroot}/images/winpe.iso
    goto MENU

    :winpe64
    initrd http://${fog-ip}/${fog-webroot}/images/winpe64.iso
    chain memdisk iso raw ||
    goto menu
    :winpe8
    initrd http://${fog-ip}/${fog-webroot}/images/winpe8.iso
    chain memdisk iso raw ||
    goto menu

    :winpetest
    initrd http://${fog-ip}/${fog-webroot}/images/winpe.iso
    chain memdisk iso raw ||
    goto menu

    :rimage
    kernel memdisk iso raw
    initrd http://${fog-ip}/${fog-webroot}/images/rimage.iso
    boot ||
    goto MENU

    :xppe
    initrd http://${fog-ip}/${fog-webroot}/images/pexp.iso
    chain memdisk iso raw ||
    goto MENU

    :easusbs
    sanboot http://${fog-ip}/${fog-webroot}/images/easuspm.iso
    goto MENU

    :easuspm
    sanboot http://${fog-ip}/${fog-webroot}/images/easuspart.iso
    goto MENU

    :acronis
    initrd http://${fog-ip}/${fog-webroot}/images/acronis2016.iso
    chain memdisk iso raw ||
    goto MENU

    :add12
    initrd http://${fog-ip}/${fog-webroot}/images/ADD12.iso
    chain memdisk iso raw ||
    goto MENU

    :aoipart
    initrd http://${fog-ip}/${fog-webroot}/images/aoaipart.iso
    chain memdisk iso raw ||
    goto MENU

    :biosupdate
    initrd http://${fog-ip}/${fog-webroot}/images/BootCD.iso
    chain memdisk iso raw ||
    goto MENU

    :msdos7
    initrd http://${fog-ip}/${fog-webroot}/images/dos71.iso
    chain memdisk iso raw ||
    goto menu

    :testusb
    kernel memdisk iso raw
    initrd http://${fog-ip}/${fog-webroot}/images/bootnet.iso
    boot ||

    goto MENU

    :freedos
    initrd http://${fog-ip}/${fog-webroot}/images/fd11src.iso
    chain memdisk iso raw ||
    goto menu

    :pccheck
    initrd http://${fog-ip}/${fog-webroot}/images/pccheck.iso
    chain memdisk iso raw ||
    goto MENU

    :hiresboot
    initrd http://${fog-ip}/${fog-webroot}/images/hiresboot.iso
    chain memdisk iso raw ||
    goto MENU

    :ultimateboot
    initrd http://${fog-ip}/${fog-webroot}/images/ubcd533.iso
    chain memdisk iso raw ||
    goto MENU

    :pfsense
    krnel memdisk
    append initrd http://${fog-ip}/${fog-webroot}/images/pfSens.iso
    boot ||
    goto MENU

    :ipxedemo
    chain http://boot.ipxe.org/demo/boot.php ||
    goto MENU

    :shell
    shell ||
    goto MENU

    :hostinfo
    cpuid --ext 29 && set arch amd64 || set arch x86
    echo This computer : ||
    echo Platform…${arch} ||
    echo Web Boot Root…${boot-url} ||
    echo MAC address…${net0/mac} ||
    echo IP address…${ip} ||
    echo Netmask…${netmask} ||
    echo Serial…${serial} ||
    echo Asset number…${asset} ||
    echo Manufacturer…${manufacturer} ||
    echo Product…${product} ||
    echo BIOS platform…${platform} ||
    echo FOG Ip Address ${fog-ip} ||
    echo FOG Web BOOT Root Directory ${fog-webroot} ||
    echo ||
    echo press any key to return to Menu ||
    prompt
    goto MENU

    :return
    chain http://${fog-ip}/${fog-webroot}/service/ipxe/boot.php?mac=${net0/mac} ||
    prompt
    goto MENU



  • @zingaro pls paste your pxe menu contents here.



  • @x23piracy
    Hi I tried initrd + chain etc… but after load ISO there are erro:
    trunc…
    numbers, number …

    press any key to start from DVD…
    the system reboot



  • Hi,

    pls show us the complete code of your pxe menu.
    This is mine and i can propperly boot all the iso’s even if AHCI is enabled and that is by default.

    :MENU
    menu
    item --gap -- PXE Boot Menu - JOS IT
    item --gap --
    item bootlocal Festplatte booten
    item --gap Betriebssystem installieren
    item win7 Windows 7 x64 Vollautomatisch! PE 4.0
    item win72 Windows 7 x64 Festplatten-Dialog PE 4.0
    item win73 Windows 7 x64 Festplatten-Dialog PE 5.0
    item --gap Partition/Image/Backup
    item acronis2016 Acronis True Image 2016
    item acronis2014 Acronis True Image 2014
    item acronis20142 Acronis True Image 2014 PE
    item acronis20143 Acronis True Image 2014 PE RT
    item easeuspms EaseUS Partition Master Server
    item --gap Password/Recovery/Restore/Repair
    item erd2005 ERD Commander Windows XP
    item dart7 DaRT 7.0 Windows 7 Server 2008 R2
    item --gap --
    item return <---
    choose --default bootlocal --timeout 60000 target && goto ${target}
    :bootlocal
    sanboot --no-describe --drive 0x80 || goto MENU
    :win7
    initrd http://${fog-ip}/iso/win7.iso
    chain memdisk iso raw ||
    goto MENU
    :win72
    initrd http://${fog-ip}/iso/win7_dialog.iso
    chain memdisk iso raw ||
    goto MENU
    :win73
    initrd http://${fog-ip}/iso/win7pe5_dialog.iso
    chain memdisk iso raw ||
    goto MENU
    :win74
    chain -ar ${boot-url}/service/ipxe/advanced.php?login=1 ||
    goto MENU
    :acronis2013
    initrd http://${fog-ip}/iso/acronis2013.iso
    chain memdisk iso raw ||
    goto MENU
    :acronis2016
    initrd http://${fog-ip}/iso/acronis2016ur.iso
    chain memdisk iso raw ||
    goto MENU
    :acronis2014
    initrd http://${fog-ip}/iso/acronis2014.iso
    chain memdisk iso raw ||
    goto MENU
    :acronis20142
    initrd http://${fog-ip}/iso/acronis2014pe.iso
    chain memdisk iso raw ||
    goto MENU
    :acronis20143
    initrd http://${fog-ip}/iso/acronis2014pert.iso
    chain memdisk iso raw ||
    goto MENU
    :easeuspms
    initrd http://${fog-ip}/iso/easeuspms.iso
    chain memdisk iso raw ||
    goto MENU
    :erd2005
    initrd http://${fog-ip}/iso/erd2005.iso
    chain memdisk iso raw ||
    goto MENU
    :dart7
    initrd http://${fog-ip}/iso/dart7.iso
    chain memdisk iso raw ||
    goto MENU
    :shell
    shell ||
    goto MENU
    :return
    chain http://${fog-ip}/${fog-webroot}/service/ipxe/boot.php?mac=${net0/mac} ||
    prompt
    goto MENU
    autoboot
    


  • @zingaro Hi, when the PCs are setting with AHCI Mode enabled,
    the ISO image ( WInpe, WIn utilities etc… ) , after load memdisk the PCs reboots …

    if change the ACHI to IDE mode all windows based tool utilities start correctly.
    I tried change the boot sintax ( memdis, sanboot ) but the result is the same.

    there are setting to boot with AHCI selected ?
    Regards



  • What a post! Problemdescription?


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.