Fog Installer - Distro check


  • Moderator

    October 22nd 2016
    FOG Version: 1.3.0 RC-14
    OS: Centos 7 v1511

    I can confirm that had the same issue on a fresh install. A cut and paste of Wayne’s code snippet fixed the issue after a quick restart of apache.



  • October 14th, 2016
    FOG Version: 1.3.0 RC-14

    • Arch Linux 2016.10.01 fully updated - installs without issue.
    • Debian 8 fully updated - installs without issue.
    • Fedora 24 fully updated - installs without issue per wiki instructions.
    • Ubuntu 16 fully updated - installs without issue.
    • CentOS 7 fully updated - fails.

    For CentOS 7, there is a message at the end of the installer that says:
    FOG Requires PHP v5.5.0 or higher. You have PHP v5.4.45
    When trying to visit the web interface, you see the same message.
    @Tom-Elliott Here is the error log from the installer: 0_1476503821634_fog_error_1.3.0-RC-14.log

    To Fix CentOS 7, install per the wiki, then run these commands:

    yum remove -y php* lib*php
    yum install https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm -y
    yum install http://rpms.remirepo.net/enterprise/remi-release-7.rpm -y
    yum install yum-utils -y
    yum-config-manager --enable remi-php70
    yum install php php-bcmath php-cli php-common php-fpm php-gd php-ldap php-mbstring php-mcrypt php-mysqlnd php-process -y
    systemctl restart httpd
    echo done
    


  • October 9th, 2016
    FOG Version: 1.3.0 RC-12

    • Ubuntu 16 fully updated - Installs without issue
    • Debian 8 fully updated - Installs without issue
    • CentOS 7 fully updated - Installs per wiki instructions without issue.
    • Fedora 24 fully updated - fails.

    Fedora fails on installing several packages, says they do not exist. Details on this coming soon.


Log in to reply
 

382
Online

5.5k
Users

12.7k
Topics

120.2k
Posts