RC10: Samsung EVO 850 SSD Issues



  • Server
    • FOG Version: 1.3.0 RC 10
    • OS: Ubuntu 14.04 64-Bit
    Client
    • Service Version: N/A
    • OS: N/A
    Description

    When imaging a computer with a Samsung EVO 850 SSD installed the imaging process is successful, but when FOG reboots the computer it can’t locate the operating system or it can’t recognize the drive. A message like this appears: “00:7ae” appears on the screen.

    When I image a computer with a Samsung EVO 840 SDD installed the imaging process is successful, and boots as intended.

    Has anyone else had issues like this? If I need to provide more information please let me know.


  • Moderator

    @Dalton-Childers So this was a problem with the image.



  • @Wayne-Workman

    Test were successful with Clonezilla, but I was still having issues with FOG.

    I decided to upgrade to latest version of the RC, which was RC 19 at the time. The imaging of an EVO 850 still failed so I decided to try something different. I created a new image on FOG and uploaded our VM to the new image (same VM used for the old image) and the imaging process worked on the EVO 850s with the newly created image on FOG.



  • @Wayne-Workman

    Thank you Wayne.

    I’ll try and get these results to you all this afternoon.


  • Moderator

    @Dalton-Childers said in RC10: Samsung EVO 850 SSD Issues:

    As for the implementation does it matter if I use a separate medium or for sanity/debug would you all like for me to get Clonezilla working over PXE via FOG?

    It doesn’t matter how you do it, long as it’s Clonezilla. We just want to know if it works or not with Clonezilla. Be that method bootable CD or USB or network, doesn’t matter. We want to know if Clonezilla can capture your image from this problematic SSD and then deploy to another computer with the same model of this problematic SSD.

    If Clonezilla is successful, keep the image files on hand because we will need to look at them.



  • @Wayne-Workman

    We are having issues with the Samsung EVO 850s and FOG 1.3.0 (Trunk Releases) combination.

    When we image a computer with a Samsung EVO 850 installed the computer will fail to boot from the hard drive. NOTE: THE SAMSUNG EVO 850s WERE WORKING FINE WITH FOG 1.2.0 AND ITS KERNEL. The main reason we upgraded to trunk was to get official support for Windows 10, since we need to upgrade around ~200 computers ASAP.

    If we install a Samsung EVO 840 into the same computer (with the same BIOS setup) the computer will image and boot successfully. The reason we’re kind of confused is the EVO 850s worked fine with FOG 1.2.0, but not with FOG 1.3.0, they fail. We are looking into different SSDs, but it’s not an ideal solution since we’ve purchased so many EVO 850s for the upgrade cycle.

    Per Tom’s suggestion, the computer has been set to “Legacy” and the image is for a Legacy system setup. I can try the flip though to UEIF for sanity sake, since we can’t really use FOG at the moment. :(

    Per George’s suggestion, I have tried this yet, but I can today. As for the implementation does it matter if I use a separate medium or for sanity/debug would you all like for me to get Clonezilla working over PXE via FOG?


  • Moderator

    To recap the issue, You have this SSD drive that won’t boot after being imaged with FOG.

    After imaging with FOG, can you take that drive and put it in a different desktop computer and see if it boots?

    Going back to Tom’s suggestion, you confirm it’s in “Legacy”. Well, what Tom was saying is he things the image might be for UEIF. Flip the setting over to UEFI in the firmware please and see what happens.

    Going back to what George asked, have you tried to capture with Clonezilla and deploy to this SSD yet? We need to know if this is successful or not, because if it is then we know that imaging it is indeed possible, where as if it doesn’t we’re still wondering what the issue is.



  • @Sebastian-Roth

    I believe, if you look on page one I uploaded a picture of the old error message. Also, after upgrading to FOG RC 17 the new error is the computer just sits on black screen with a single blinking underscore. Nothing else is displayed to the screen.


  • Developer

    @Dalton-Childers said:

    A message like this appears: “00:7ae” appears on the screen.

    You know I am very keen to figure out those very wired “low level” disk issues. I think it would be very helpful to see the actual error you get on screen in a picture. Can you please take one and upload here?



  • @Tom-Elliott @Wayne-Workman @george1421

    I checked the Samsung EVO 850s for firmware update, but according to Samsung’s site no updates have been released. I have also spent the last week or so trying different kernels between 1.2.0 and 1.3.0 versions of FOG with no success.

    It’s just odd that the Samsung EVO 850s were working fine with FOG 1.2.0, but fail when imaged with FOG 1.3.0. Also, I’ve tried RC 17, but the image was unsuccessful with it as well.



  • @Tom-Elliott I just checked to be sure and the boot mode is set to Legacy. I’ll try one of those kernels.


  • Senior Developer

    @Dalton-Childers It almost sounds like the device is setup to boot through UEFI? I know that sounds weird because you replacing the 850 with an 840 all seems to work fine. The fact that it’s saying no OS is being found is what’s making me think there’s an issue.

    You might want to try deploying the system with a 4.4 kernel or even 4.5 is possible. 3.18 is very old and likely didn’t have the drivers needed to even recognize the SSD.



  • @george1421 The image is a windows image.


  • Moderator

    @Dalton-Childers While I can’t answer anything about the command Tom posted I will give you a hint. If in the FOS command shell, you give root a password with passwd you can connect to the FOS linux via ssh (putty or what ever). That will allow you to do screen grabs and what not instead of having to take pictures with a mobile.

    Now that I look at that picture again, are you deploying linux to the EVO 850 or Windows? That looks suspiciously like a windows disk structure.



  • @Tom-Elliott @george1421

    0_1475719288775_Screenshot 2016-10-05 21.01.03.png 0_1475719302347_Screenshot 2016-10-05 21.01.08.png 0_1475719313085_Screenshot 2016-10-05 21.01.13.png 0_1475719332160_Screenshot 2016-10-05 21.01.18.png

    ^ Requested output of fdisk -l



  • @Tom-Elliott @george1421 The kernel test failed.

    Also, when you press F12 and select the hard drive as the boot option. It responds with the standard can’t find a bootable drive error. When you let it run thought pxe then fog then boot from hard drive you get the error I posted above.


  • Moderator

    @Dalton-Childers To Tom’s point about " go into a debug and get output of fdisk -l "

    What he was recommending is on the system you just imaged. Schedule a new image right away, BUT on the scheduled task page enable the checkbox for debug deploy. Then pxe boot the target computer. This will tell the FOS Engine to boot on the target computer, display a bunch of text and after a few presses of the enter key drop you to a command prompt on the target system. This is the command shell for the FOS Engine (the linux OS that captures and deploys images on target devices). Obviously this OS can see the 850 EVO. Then run the fdisk -l command and post the output here.

    BTW: I don’t think kernel 3.18 will work with the new initz. You will probably get a kernel panic when your try to pxe boot it. But that is only a guess, and I’m a bad guesser.



  • @Tom-Elliott I’ve reverted back to kernel 3.18.2, because I found refers to that being the primary kernel for FOG 1.2.0. I’ll let everyone know if that resolves the issue…if not I’m going to try imaging a working computer (done with FOG 1.2.0) and drop the image on the EVO 850 using FOG 1.3.0.



  • @Tom-Elliott
    0_1475717499709_Screenshot 2016-10-05 20.30.53.png

    I hooked the drive into my Mac Pro and ran diskutil list, which return the above bit of information.

    0_1475717652847_Screenshot 2016-10-05 20.33.47.png

    The above image is sudo fdisk disk.



  • @george1421 Per your questions about the drives, they were both straight out of the box with no OS installed previously.


Log in to reply
 

494
Online

38916
Users

10685
Topics

101360
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.