FOG Management page unreachable after svnserve install/configure



  • Server
    • FOG Version: 1.2
    • OS: Ubuntu 12.04
    Description

    Not too long ago I successfully set up a FOG server on a Linux VM, was able to image a few machines as well, haven’t yet had to use them as they are for DR purposes mostly. More recently I had been approached by one of our software guys who was looking to get a SVN repository server set up on the machine as well. I installed and configured svnserve, but now when I try to access the FOG management page it loads the directory as an un-formated svn repository, here. Insight anyone? Tried reinstalling FOG using the settings specified in my previously working copy. No dice. Just a hunch but my first inclination is settings in apache2, I don’t really know where to start looking though.


  • Moderator

    @wanderbread ok… so Ubuntu 12 isn’t recommended for the new fog 1.3.0 release candidate, and upgrading Ubuntu has always ended in fog disaster. And your current installation is messed up and on a very old OS, and running a fairly old version if fog.

    You need to rebuild.

    I’m going to recommend to you that you make a copy of your images to somewhere, they are in /images and then backup your database with thus command and put this somewhere safe too: mysqldump fog > fogdb.sql

    And then nuke this server and install something recent like CENTOS 7 or Ubuntu 16, use the same IP, and install fog 1.3.0 release candidate, and after that is done, backup the new database with tge same above command, then import the old database, and move images back over.



  • @Wayne-Workman I killed subversion. Nothing, still showed up as an unformated repo, (repos still on the vm were still available too, via browser). Uninstalled subversion. Nada, repos still accessible via browser across our network. Uninstalled, purged apache2, renamed /etc/apache2/ which held some files used by subversion. Reinstalled apache2, fresh /etc/apache2 dir, but now: this.


  • Moderator

    @wanderbread that’s not a very good error, it’s trying to treat fogs web files as a svn repo.

    I think these two things probably shouldn’t co-exist. Try to Uninstall svnserve.

    If that doesn’t work, we should start talking about getting the images and hosts off that box, and onto a fresh box.



  • svnserve does have a web interface. here. The error message that’s generated when I try to access fog is as follows:

    [Tue Oct 04 17:18:23.485189 2016] [dav:error] [pid 16632] [client 192.168.10.28:58477] Could not open the requested SVN filesystem [500, #2]


  • Moderator

    No idea. Sounds like js isn’t working. Does svnserve have a web interface? If so, it might have overwritten things in Config files as you suggested. Are there any errors in the apache error log?


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.