SOLVED ntfsclone-ng.c: NOT NTFS partition, ntfs mount error 5

  • Server
    • FOG Version: 1.2.0
    • OS: CentOS 6.8
    • Service Version:
    • OS: Windows 7

    Hello All,

    I’ve just upgraded from 0.32 to 1.2.0 and it was easier than I expected, until I got to uploading an image from client to the server.

    I have VM with Windows 7, Single Disk - Resizable. The beginning of the process looks good, the resizing take some time (~15 minutes) and it ends with “Done”, then the first partition (Windows boot, 100MB) is uploading, and then when it comes to /dev/sda2 an error occurs:

    Partclone v0.2.69
    Starting to clone device (/dev/sda2) to image (/tmp/pigz2)
    Reading Super Block
    ntfsclone-ng.c: NOT NTFS partition, ntfs mount error 5

    What could possible cause the problem? That VM worked as a golden image with 0.32 for years, without and problems.

    best regards,

  • @Wayne-Workman i am also have the exactly the same error, are there any document that walk you through upgrading for fedora 23?

  • It took me some time to upgrade, because we are using it in a production environment, but after upgrade the problem is solved.

  • The way .32 and 1.2.0 handled things were really different. .32 was very solid - but it’s old, it can’t support newer hardware, newer disk types, newer HDD types like nvme, flash, hybrid drives, SSD, and it can’t handle GPT type disks, or UEFI booting. 1.2.0 wasn’t any better at any of these things but had a newer linux kernel. But 1.2.0 made a lot of assumptions about the disk which made it difficult to work with.

    Would you be willing to upgrade to the release candidate for 1.3.0? What OS is your FOG server running on, first?

  • @Wayne-Workman

    MBR layout, with 2 partitions (100MB NTFS Windows System Reserved and 230GB NTFS C:).

    Screenshots from Upload-Debug attached.


    I tried Multiple Partition Image - Single Disk (Not Resizable) type, and it works fine.

    best regards,

  • Is the hdd in a GPT layout or a MBR layout? How many partitions does the image have? And can you give us a photo of the error?