UNSOLVED FOG Node - getversion.php Missing


  • Server
    • FOG Version: 1.3.0-RC-8
    • OS: Ubuntu Server 14.04
    Client
    • Service Version:
    • OS:
    Description

    Hi all,

    I’ve just set-up my FOG storage node, although I can’t seem to see it from the web gui dashboard. When selecting it, I see a long line of text that says:
    0_1474992725961_Capture.PNG

    “The requested URL /fog/service/getversion.php was not found on this server.”
    Would anyone be able to tell me where I can get this from or what I need to do to ensure it shows up correctly on the GUI?

    Any help with this would be greatly appreciated.


  • @Wayne-Workman Indeed - many thanks for your help 🙂


  • @RobTitian16 said in FOG Node - getversion.php Missing:

    I wonder if it’s the way I installed the storage node? I did:
    cd /opt
    sudo wget http://downloads.sourceforge.net/freeghost/fog_1.2.0.tar.gz
    sudo tar -xvzf fog_1.2.0.tar.gz
    cd fog_1.2.0/
    cd bin
    sudo ./installfog.sh

    A 1.2.0 storage node will never work right with a 1.3.0 server.


  • @Tom-Elliott Excellent - that’s fixed it! Many thanks 🙂


  • @RobTitian16 That’s because the file simply doesn’t exist on the remote node.

    For the node that’s giving the issue can you run:

    rm -rf /var/www/fog /var/www/html/fog
    

    Update your fog installation folder as needed (either git pull or svn up) and rerun the installer?


  • @Tom-Elliott Ah, thanks for that. I can now run: mysql -h hostHere -u userHere -pPasswordhere -D fog on the node and connect in to the database on the FOG server. However, it’s still not showing correctly on the GUI… it’s still showing the same thing, even when using the same credentials to add the storage node.


  • @RobTitian16 You need to run that on the main server, not the node.


  • @Tom-Elliott I tried doing that, but I receive the following error:

    0_1475581444954_Capture.PNG

    As you can see, I then tried to find the file it referenced, but it seems like it hasn’t been installed… have I installed the FOG node wrong somehow?


  • @RobTitian16 If bind-address is already commented, then you might need to change the ‘fogstorage’@’%’ password.

    I think you can do this if you login as the mysql ‘root’ user.

    mysql -u root
    SET PASSWORD FOR 'fogstorage'@'%' = PASSWORD('fs22290863734');
    exit
    

  • @Tom-Elliott 0_1475575997253_Capture.PNG

    bind-address already seems to be commented out. Is there anything else I can check?
    And yes, I can ping the server perfectly fine from the problematic node.

    I wonder if it’s the way I installed the storage node? I did:

    cd /opt
    sudo wget http://downloads.sourceforge.net/freeghost/fog_1.2.0.tar.gz
    sudo tar -xvzf fog_1.2.0.tar.gz
    cd fog_1.2.0/
    cd bin
    sudo ./installfog.sh

    And then from the installation menu, selected to install the node.
    I’m currently running Ubuntu 14.04, the same as my FOG server.
    Perhaps I need to update the version of the FOG storage node? Is it the same process as updating the FOG server?


  • @Wayne-Workman YOu should remove bind-address entirely.


  • @Tom-Elliott What is the preference at the moment? 127.0.0.1 or localhost ?


  • More often than not, this is because of the “bind-address” configuration setting in /etc/my.cnf (your location might be /etc/mysql/my.cnf, or elsewhere from however ubuntu decides to layout the configuration).


  • @RobTitian16 Can you successfully ping the main fog server from this problematic storage node?


  • @Wayne-Workman
    Yes, this is the message I receive:
    0_1475493765057_Capture.PNG

    I can confirm that username and password is the same as what’s listed in the FOG Configuration settings. The IP address is also that of the main FOG server.


  • @RobTitian16 The fields you found are what I was referring to, I just didn’t remember the names right. I’ve been AFK for a few days now, just working off my laptop.

    So, when you plugin the database host, user, and pass into the command I gave you, exactly what happens? Can you give us a screenshot of it please?

    Also, is the password and user you see in there the same as the password found in Web Interface -> FOG Configuration -> FOG Settings -> Storage Nodes -> Password and User ? Is the IP address in there the one of the main fog server?


  • @Wayne-Workman Hi all, apologies about the delay in getting back to you.
    I’ve gone through Wayne’s suggestions and yes, I can confirm I used the fog installer to setup the storage node.

    I ran the cat /var/www/html/fog/lib/fog/config.class.php command, but couldn’t see snmysqlhost, snmysqluser or snmysqlpass there at all near the top. Instead, I saw define “(‘DATABASE_HOST’,),” and the same for the database username and password. There was no record of snmysqlhost, so I’m not sure if this is an issue itself?

    I tried running the test with the information I did have, but that came back with an error 2003(hy000) which, after a Google search, shows that the connection isn’t working correctly.

    Finally, the getversion file does seem to be missing. After running your suggested command, nothing was returned at all.


  • I’m guessing the last part of @Wayne-Workman will lead us to the answer.


  • Why is it unlikely the file simple really doesn’t exist? If it were a DB connection issue I would think it would return an error 500. Maybe even an error 502, but 404 is almost always “the file doesn’t exist” or cannot be accessed due to permissions.


  • @RobTitian16 I should ask, did you use the fog installer to setup this storage node?

    and, if you run the command cat /var/www/html/fog/lib/fog/config.class.php on the storage node, it’ll output some variables. Three of them will be snmysqlhost and snmysqluser and snmysqlpass They will be towards the top.

    You can test those manually from the storage node via CLI as:
    mysql -h hostHere -u userHere -pPasswordhere -D fog

    Note that there’s no space between the -p and the password, that is intentional. If it lets you in that way, the DB connection is good. Else, it’s bad.

    Also, I doubt the getversion file is actually missing. You may search for it with this:
    find /var/www/html/fog | grep /getversion.php

333
Online

9.0k
Users

15.6k
Topics

145.2k
Posts