SOLVED When trying to boot to hard disk from PXE menu I get a blinking cursor.

  • Server
    • FOG Version: 1.3.0-RC-8
    • OS: Ubuntu 16.04
    • Service Version: Not sure I’m assuming the same.
    • OS: Windows 10
    • Specific Machine: Lenovo ThinkPad P50

    So we have FOG in our environment and testing has been going well thus far, however setting the PC’s to boot into PXE first, won’t allow the PC to boot to it’s hard drive after the PXE menu.

    I have tried using the ‘sanboot’ and ‘exit’ exit types. With sanboot is when I get the black screen with a blinking cursor and with exit it states that chainloading failed and the system restarts.

    Also to note that after an image task the OS will load, but upon reboot when it goes to the FOG PXE screen and tries to load from hard disk is when I’m having issues.

    Any help would be awesome! Thanks

  • Moderator

    @zln1996 Sure no problem. Here is the article, the 2012 section is below the linux section.

  • @george1421 Thank you though! I believe we may be okay since most of our computer’s in the organization are new so they should all use ipxe.efi. We will be doing a migration to Server 2012, sometime in the near future, luckily I’m a lot more familiar with 2012’s interface and layout. Could you point me to that article still? I would like to see it before going live with the migration.

    Also just wanted to thank you again for the help!

  • Moderator

    @zln1996 OK then. Unfortunately, you will have to manually change between the two iPXE kernels. I just thought we could save you some grief with one of our wiki pages that shows how to set this up for 2012 dhcp server.

  • @george1421 No Windows 2008 R2.

  • Moderator

    @zln1996 Is your dhcp server based on windows 2012?

  • @george1421 Okay that’s where my confusion was, the only boot file that I knew of was undionly.kpxe I didn’t know there was one designed for UEFI. So now when I boot into PXE using UEFI instead of legacy it works now that I’ve configured the server to send ipxe.efi.

    Sorry for not being clear earlier yes it is an UEFI system.

    So i changed the FOG_EFI_BOOT_EXIT_TYPE to refind efi and it boots to windows! Sanboot made it loop in the fog menu and exit gave the same “chainloading failed” screen.

    Now I’m gonna test deploying an image and make sure it goes through the entire thing!

    Thanks for the help guys!


    It worked! Completely unattended! Thank you guys so much for the help!!!

  • Moderator

    @zln1996 Lets get a few things straight (not meant as harsh as it sounded).

    Your target computer is either in bios (legacy) or uefi mode. The devices are not typically flexible they are either in bios or uefi mode. Once you know the mode of the target computer you need to be sure you send the right iPXE kernel to the target computer.

    Typically bios (legacy) computers will boot with undionly.kpxe, and typically uefi systems will boot with ipxe.efi. If your dhcp server is a windows 2012 server you can configure the windows dhcp service to send out the right boot file based on the target computer type.

    Once the target computer has the right iPXE kernel it should boot no problem. The next issue you will have to uefi systems (as well as bios sometimes) is the exit from the FOG iPXE menu. This is controlled by the exit mode (either globally or defined on a per host basis). You need to test each exit mode with each hardware if sanboot doesn’t work as a global exit mode. This is all configurable, you just have to understand where to look.

  • Hey Tom and George,

    The UEFI BIOS version is N1EET52W. As for the boot file I’m using undionly.kpxe and the way I have the BIOS to boot is both UEFI and Legacy where Legacy is first. The reason for this is because when I have it set to UEFI first and try to PXE boot it won’t ever load the PXE menu, but on Legacy it works.

    I switched the exit type to rEFInd and get the same blinking cursor.

    Using grub it states “Starting CMAIN()…” and then just a blinking cursor it’s been that way for about 5 mins now, so I’m writing this post while monitoring it.

  • @zln1996 what’s the boot file you’re using to get the ipxe menu? It sounds like you’re using an EFI file but you’re trying to use legacy methods to load up.

    Maybe try rEFInd or grub? Also you may like to update to RC 11 to ensure issues from 8, 9, and 10.

  • Moderator

    Since you have a Win10 OS, I would think your firmware would be uefi right? If that is the case you will need to adjust the uefi exit mode for that system, possibly to refind if one of the other exit modes don’t work. You may need to configure the refind program a bit more too. But lets first identify what firmware mode this thinkpad is in.