An error has been detected! No resizable partitions found.



  • I’m trying to upload a new windows 7 Ent. 64 to an HP Elitebook 850 G3 and I’m getting this error (Image type, single-resizeable):

    An error has been detected!
    No resizable partitions found.

    I tried setting the image to non-resizeable single disk but it just gets stuck on “found drive /dev/sda” and never progresses.

    From scouring other fog posts this could be related to TRIM function on the ssd?

    I’m getting tired of the bleeding edge… :/ every 3 years on the new leases I run up against some issue, its getting old.

    Thanks,
    Rama



  • Appears to be working, will let you know once the image is uploaded if it still boots :)



  • Thanks for the replies. I am using “Version: 1.2.0”. I’ll give the fixparts a try.
    The original image was windows 10, I wiped the disk and installed 7, then sysprep’d and tried to “upload” the image to fog at this point.
    It’s highly likely that it is GPT, I forgot that could cause issues.
    I’ll let you know how I get on.

    Rama


  • Senior Developer

    Based on what I’m gathering you’re trying to capture a master image?

    The point that you stated about it just getting stuck at /dev/sda1 indicates to me that the system you’re using came preloaded with an OS, and rather than start from scratch you creates it by converting it to an MBR style. This further tells me that the original system used GPT for the disk layout rather than MBR.

    To fix this you will need to recreate the task using one of the debug modes, most likely (Capture/Upload - Debug.). To get there, go to the host in question on the GUI. Choose Basic Tasks. Click on Advanced. Look for capture or upload debug. Click it and confirm you want to do this. Boot the host.

    It will boot like normal except instead of starting the task right away it will drop you into a command line interface.

    Type fixparts /dev/sda. Make the confirmations as requested. Once complete you can cancel the debug task and reschedule the tasking under normal means. Or you can start the actual main tasking by just typing fog in the terminal.


  • Moderator

    What version of FOG are you using?

    The word “upload” is a bit confusing since its based on point of view. Are you capturing or deploying the image. Upload/download words makes me thing you are using fog 1.2.0 stable??


Log in to reply
 

362
Online

38989
Users

10713
Topics

101692
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.