DHCP Timeout after Linux begins to boot



  • Hey all,

    Unfortunately this looks like a duplicate of https://forums.fogproject.org/topic/4048/dhcp-lease-timeout-issue, but that happened about two years ago. I’m trying to set up FOG in a lab that has Spanning Tree enabled, so switches won’t open the port for about fifteen seconds after the NIC comes up. The FOG init tries to get a DHCP lease a few times, fails, then prompts to reboot the system.

    In the linked forum post, it’s stated that a 60 second timeout was added. I assume that this changed at some point. How would I be able to add this delay back so that I’m able to successfully use FOG tools on them?



  • The switch did not support any faster methods of STP, or they did not work. Disabling STP altogether is a calculated risk that we took, and it has fixed the problem.

    This issue is solved.



  • The unmanaged switch works until I can get into the switches to enable a different STP.



  • Understood. I’ll see what I can do and report back. I won’t be in that lab for a few hours.


  • Moderator

    @2cool4me4 put an unmanaged (dumb) switch between the building switch and the target computer.



  • Thanks, george. I’ll see if I can get that done. I might not be able to, though. Is there any workaround that I can use to get this running until I’m able to make the change?


  • Moderator

    You can have spanning tree enabled (and should), but you need to enable one of the fast stp protocols (port fast, fast stp, rstp, and a few others I can’t remember). Standard spanning tree takes 27 seconds to start to forward data while it listens for other infrastructure devices.

    And yes (depending on what version of fog you’re running the boot process has changed greatly).


Log in to reply
 

490
Online

38962
Users

10707
Topics

101593
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.