Failed to add snapin, unable to locate snapin directory.



  • Hey,
    First of all, thank you very much for this project!
    finally a cloning solution that works, and really easy to manage. YOU ROCK!

    Well, Im trying to add snap-in (just a test snap-in for now) of a batch file.
    This snap-in will just open google chrome on the target workstations and nothing else.
    When Im trying to add the snap-in i get an error "Failed to add snapin, unable to locate snapin directory."
    I searched to that online, and saw some comments says to update fog.
    I just updated fog to 1.3-RC10 - didnt fixed it.

    I saw about checking all the ftp credentials - did that, and still the same. (According to this link - https://wiki.fogproject.org/wiki/index.php/Troubleshoot_FTP#Credentials_.2F_Passwords).

    I havent seen anything else online, so Im asking here for help.

    tnx again,
    Niv.



  • @Wayne-Workman
    Thank you Wayne and Tom for your replies.
    I guess i didnt understand the idea of snapins, anyway, now I do.
    Eventually, I solved the problem with creating a new path to the sanpins.

    Regardless of this problem, I have another one now.
    I just noticed that since updating to 1.3.0-RC-10, I cant capture any machine.
    The progress is stuck on the client, like this:
    0_1474521399902_fog-stuck-on-mountingfilesystem.JPG

    im trying to capture an image i already captured, just for testing, I left it all night and it didnt continued…
    Im sure about the settings i set for the new image, since its the same as the image settings that already deployed to the machine.

    Should I post a new topic about this or wait here for help?

    Niv.


  • Moderator

    @nivbehar said in Failed to add snapin, unable to locate snapin directory.:

    This snap-in will just open google chrome on the target workstations and nothing else.

    While the error you get needs solved, the new fog client will never be able to “open” something for users to interact with, all snapins run as the SYSTEM user, and the system user is not allowed to interact with users nor have any display or output at all, by design of Windows itself.


  • Senior Developer

    @nivbehar the path looks fine one my side, the other way it may return it cannot locate might indicate the FTP user and password are incorrect. I doubt that’s the issue though as if the credentials are wrong it will present an error stating as suck. Can you add a trailing / in the path?



  • @Tom-Elliott
    Hey Tom!

    do u mean the Storage node?
    i have only the default, and it look ok:

    0_1474361441423_storage-node-fog.JPG

    regards
    Niv.



  • do you mean “who” is the owner of the folder?
    this is how it looks like through winscp:

    0_1473947246924_opt-fog-snapins-permissions.JPG


  • Senior Developer

    Snapin paths are set per node now. Can you check on each node and validate the snapin paths?



  • @nivbehar What about ownership? and my Perms are set to 775, but technically 777 would work. It might have been ownership



  • do u mean setting permission in /opt/fog/snapins to 777 ?
    i did that too…didnt work :(



  • I would assume if you didn’t have the correct permissions on the snapin directory, it would tell you so, but it is telling you it cannot locate it. However, IIRC, you have to update the snapins directory permissions. At least I remember having to manually change perms back when I set my server/nodes up.

    Someone want to correct me? (I don’t know if this has changed since before RC releases)


Log in to reply
 

400
Online

39.3k
Users

11.0k
Topics

104.5k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.