Network Interfaces missing from capture - Debian 6 kernel 2.6



  • Hello i have just setup my Fog Server and i tried to create a new image . When i click on create new image link i get a blank page with “Add new image definition” on top and nothing else . I cannot create any images and i don’t see any error , can you please help ?


  • Senior Developer

    @Wayne-Workman add a note that this is specific to Linux images. This same step would not work on Windows based images



  • #wiki worthy. And good job.



  • I found the solution if anyone is wondering turns out i had to remove /etc/udev/rules.d/70-persistent-net.rules after deploy



  • Anything on this ?



  • Here is lspci output:

    root@satbox:~# cat out.txt
    00:00.0 Host bridge: Intel Corporation N10 Family DMI Bridge (rev 02)
    00:02.0 VGA compatible controller: Intel Corporation N10 Family Integrated Graph ics Controller (rev 02)
    00:02.1 Display controller: Intel Corporation N10 Family Integrated Graphics Con troller (rev 02)
    00:19.0 Ethernet controller: Intel Corporation 82567V-3 Gigabit Network Connecti on (rev 04)
    00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 04)
    00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (r ev 04)
    00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controll er #1 (rev 04)
    00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controll er #2 (rev 04)
    00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controll er #3 (rev 04)
    00:1d.3 USB Controller: Intel Corporation Device 2833 (rev 04)
    00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Control ler #1 (rev 04)
    00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f4)
    00:1f.0 ISA bridge: Intel Corporation 82801HEM (ICH8M) LPC Interface Controller (rev 04)
    00:1f.2 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA IDE C ontroller (rev 04)
    00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 04)
    01:07.0 Ethernet controller: Intel Corporation 82541GI Gigabit Ethernet Controll er (rev 05)
    02:00.0 Ethernet controller: Intel Corporation 82583V Gigabit Network Connection



  • I cant do that at the moment will update on Monday . Thank you.

    Edit the card are : Intel 82567V-3 Gigabit
    Intel 82583V Gigabit
    Intel Pro/1000 MT



  • @kleanthis What is the NIC, what model of computer is this happening on? Can you run lspci and give us the output?



  • Sorry found it i downloaded an older kernel and left default name do i need to recapture or just redeploy ?

    Tried full recapture and redeploy : still no interfaces found , tried with oldest kernel 3.0.1 my Debian is running on 2.6.32 . Is there a specific kernel for this?



  • This post is deleted!


  • @kleanthis The new kernel may not be seeing them. Try older kernels and if you find a version that works, tell us what it is.



  • Got it fixed thank you . One more thing i have capture a debian 6 image but when deploying that on same hardware it doesnt detect eth0,tun0 and other network interfaces only lo interface . It sais no such device where as on the original server there are all there , do you know this might be happening ?



  • @kleanthis It installs fine on Debian 8, why not use Debian 8? We are a small team, we do our best to make the latest distributions work.

    Of course the server itself can be the storage.



  • I am using a Debian 7 server as the storage server with 1.2.0 because i cannot install 1.3.0-rc9 on on it , it give error : * Installing package: php5-fpm…Failed! for 1.3.0-rc9 . Will this work ?

    Also can the server itself be the storage ?



  • Cool, thanx will try and update .



  • @kleanthis Be aware that at the moment, rc-9 has some issues with snapins. You’ll want to move to RC-10 as soon as it’s out.


  • Moderator

    @kleanthis It uses an absolute path, so anywhere, really.

    Permissions are best kept on 777



  • With 1.3.0-RC9 it works , one more thing though , i have installed the Storage Server on another server but i dont want the default path to be the one to use but instead another . Does my path have to start from the /var/www location or can it be anywhere on the server? Also what permissions must a custom location have ?



  • Updating to trunk now and will see how it goes.



  • Also: https://forums.fogproject.org/topic/2928/image-management-blank-page

    And the storage pie being missing makes me think FTP credentials, 1.2.0 used FTP for that I think.

    If you get it fixed, I’d advise moving to trunk like Quazz said.


 

468
Online

41.9k
Users

12.4k
Topics

116.7k
Posts