PXE issue - file not found?



  • Got Fog server up and running, set my DHCP settings as per the install notes. Can access fog server remotely with //ipaddress/fog

    On the client side, enabled PXE booting in the bios. Booting to PXE gives an error “file not found” . DHCP server is a Win 2008 R2 server. I’ve tried changing the path for the ftproot folder.

    The client installer on the windows machine gave me a write error, about not able to write to registry. Can this be the culprit?


  • Moderator

    There is a great section in the user guide about uploading your first image.



  • I ended up doing exactly that. Tested it out, my client machines are getting the info via PXE now.

    Now I just have to figure out how to create the actual image package, but Im sure that’s in notes someplace online. Already have the software I want installed. I have general newbie questions that I’ll try to answer myself tomorrow.


  • Moderator

    If you continue to have problems with 12.04, I suggest installing 10.04 and Fog 0.32. The combination seems to work really well.



  • yeah I meant dnsmasq, not proxydhcp… Anyhow, Im reinstalling 12.04 from scratch, I’ve reconfigured the raid on the server to give me a 200 GB storage space on the fog server. So, once I can find a configuration that works to boot via PXE, I should be good to go. We’ve got quite a few computer labs to reimage over the summer, so here’s to hoping I can get it working smoothly!


  • Moderator

    Before you try the proxyDHCP stuff, make sure your tftp server is working on the Fog server. Ubuntu 12.04 has made some changes and people are having minor issues getting Fog to work without modification. I think you might have to make a configuration change in the TFTP server to get it to work with 12.04.

    From another machine, see if you can TFTP into the fog server. something like:
    [CODE]c:>tftp -i 192.168.1.24 GET pxelinux.0[/CODE]
    [B]Note:[/B] In Windows (you may have to install additional windows features to get TFTP client or download one from the internet)



  • Hi Chad,

    Yup, set those two options on the DHCP server.

    Fog server is on Ubuntu 12.04 (hardware is a Dell poweredge server, 2.ghz processor), Fog software version is 0.32.

    I went back and formatted the server, reinstalled Ubuntu, to undo some possible mistakes. Going to try the proxydhcp tool tomorrow.


  • Moderator

    I don’t think the client error has anything to do with PXE boot not working.

    You are using a Windows Server 2008 R2 for DHCP. Did you configure the DHCP Option 66 and 67 for the scope?

    Option 66: IP of TFTP server (normally your Fog server IP address)
    Option 67: pxelinux.0

    Tell us what Fog server OS and version you’re running and which version of Fog.


Log in to reply
 

365
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.