FOG Client an DHCP on Win 7



  • Hello,

    I have the following problem.

    If my PC running with DHCP, the connection does not work with the server.
    I get the following error in the log end.

    bei System.Net.WebClient.DownloadDataInternal(Uri address, WebRequest& request)
    bei System.Net.WebClient.DownloadString(Uri address)

    I ask the client to static IP addresses to all works. The problem is reproducible with three devices.tested with the stable client and the version from the trunk. In both cases the same result.Does anyone know this problem and there is possibly a workaround? Unfortunately, a switch to static address is not in question.

    Thanks


  • Moderator

    @coldenburg Did you try a mini-switch yet?



  • Server and Clients are in the same Network. It is a test environment and the installation of an Image via DHCP and PXE works fine.
    the error message rather indicates a problem of Fog clients. I then found by searching a similar entry in a C # mailing list.

    Again the error image.
    If the client has entered a fixed IP address on Windows Network Configuration works to communicate with the fog server.
    If the same client set to DHCP on Windows Network Configuration does not go communcation and there are these error messages in the log file.
    System.Net.WebClient.DownloadDataInternal(Uri address, WebRequest& request)
    System.Net.WebClient.DownloadString(Uri address)


  • Moderator

    You’re talking about DHCP being enabled on the hosts in your environment? If that’s the case, sounds like you have a spanning tree / portfast issue - misconfiguration of these things creates a gigantic swirling packet storm of death, basically. Put a mini-switch between the computer and the building network, see if DHCP works.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.