Manually copy image between FOG hosts



  • I have two FOG hosts at the latest GIT pull. I’m trying to move a single image from server 1 over to server 2. I am able to copy the files fine and I took the steps Tom suggested (in another post to):

    touch /images/{.mntcheck,dev/.mntcheck}
    chmod 777 -R /images
    

    I then went into the FOG Images area and created a new image, pointing it to the new location in /images/Win7Image (this is not the name of the folder from the original FOG 1 server, I’ve renamed this on FOG 2).

    This is not an operational image. We get an NTFS resize error when trying to deploy it and it gives no bump to the storage chart on the dashboard (still remains the size before copying) and is missing the data for size on Client.

    Any advice on how to troubleshoot this, or properly move files between FOG servers? I’m not looking to replicate all of my images, that’s inappropriate. I just need this one.



  • All set - it was the files being sent to a single filename * - that was just a syntax error on my part for using the Windows cli too often.

    @Wayne-Workman - i had to change my /opt/fog/.fogsettings file back to pointing the storage at ‘/images’ because the entire imaging process breaks. Also re-added my /etc/fstab line to point /images to the home directory where the 177G volume is. I understand you think my system will fail if I fill up more than the 50G available on the root drive, I’m confident it won’t. Thank you greatly for your assistance, it was the file copy problem.


  • Moderator

    @Chris-Shipley said in Manually copy image between FOG hosts:

    but the graphic still shows /images as the Image Path and FTP Path.

    You would just update those via the web interface. The installer doesn’t touch much of anything in the DB, it’ll add a new node for you, and make sure you’re node’s FTP credentials are correct, that’s all it does to the DB for an existing setup - and of course it updates the db schema if necessary. It doesn’t do anything beyond this because there’s no way to know what the admin’s intentions are, or what unique setup there may be. For instance, you might have 3 or even 12 nodes defined all on one server, all with a different path. Imagine the disaster if the installer was programmed to just ‘correct’ all of those for you…



  • I re-ran the installation after setting the proper path in /opt/fog/.fogsettings but the graphic still shows /images as the Image Path and FTP Path. I look in /etc/exports and see:

    /home *(ro,sync,no_wdelay,no_subtree_check,insecure_locks,no_root_squash,insecure,fsid=0)
    /home/dev *(rw,async,no_wdelay,no_subtree_check,no_root_squash,insecure,fsid=1)
    

    Here is my /opt/fog/.fogsettings:

    ## Start of FOG Settings
    ## Created by the FOG Installer
    ## Version: 1.3.0-RC-8
    ## Install time: Tue 21 Jun 2016 02:14:52 PM EDT
    ipaddress='10.10.2.18'
    interface='enp2s0'
    submask='255.255.254.0'
    routeraddress='10.10.2.1'
    plainrouter='10.10.2.1'
    dnsaddress='# No dns added'
    username='fog'
    password="rFwfWrtWZmX/2nxUy3mvV1R99pOr2iiKvSBErGFXBCA="
    osid='1'
    osname='Redhat'
    dodhcp='N'
    bldhcp='0'
    dhcpd='dhcpd'
    blexports='1'
    installtype='N'
    snmysqluser='root'
    snmysqlpass="somepass"
    snmysqlhost='127.0.0.1'
    installlang=''
    donate='0'
    storageLocation='/home'
    fogupdateloaded=
    docroot='/var/www/html/'
    webroot='/fog/'
    caCreated='yes'
    startrange=''
    endrange=''
    bootfilename='undionly.kpxe'
    packages='curl gcc gcc-c++ gzip httpd lftp m4 make mariadb mariadb-server mod_ssl net-tools nfs-utils php php-bcmath php-cli php-common php-fpm php-gd php-mbstring php-mcrypt php-mysqlnd php-process tar tftp-server vsftpd wget xinetd '
    noTftpBuild=''
    notpxedefaultfile=''
    sslpath='/opt/fog/snapins/ssl/'
    backupPath=''
    php_ver=''
    php_verAdds=''
    fogguiuser='fog'
    fogguipass='password'
    ## End of FOG Settings
    


  • This post is deleted!

  • Moderator

    @Chris-Shipley said in Manually copy image between FOG hosts:

    Also, what code do I use to get this red stuff: Is there a quick reference for forum codes?

    The slanted apostrophe looking thing to the left of the 1 key on a U.S. keyboard. Put text in a pair of those and you get red text.

    /etc/exports should have two entries, for the images directory and the dev directory, wherever those are. If you correct storageLocation= inside of /opt/fog/.fogsettings and re-run the installer, it’ll write the exports file correctly. The FTP path and Images path in the web interface should simply be the true path of where the images are.



  • @Wayne-Workman So, now that I’ve changed the /opt/fog/.fogsettings file, I have this problem in my storage:
    0_1472588151215_upload-0f863287-6fc6-4919-aa43-79415fd5fb1e Where do I these Image Path and FTP Paths? Or should I have kept my /etc/fstab file entry?

    Also, what code do I use to get this red stuff: 0_1472588300846_upload-ce9ddc6c-1936-4d61-87cb-7afebf53bd3a Is there a quick reference for forum codes?


  • Developer

    @Chris-Shipley said:

    yeah, SCP syntax for the lose - i’m re copying

    I’d be really interested to see the command you used to copy last time - ending up with just a single file named *. This is very advanced bash foo magic I reckon. I wasn’t able to do this even trying hard.



  • @Sebastian-Roth yeah, SCP syntax for the lose - i’m re copying


  • Developer

    @Chris-Shipley said:

    [root@localhost Win7Image]# ls -lahRt /images/Win7Image
    /images/Win7Image:
    total 13G
    -rwxrwxrwx.  1 root   root  13G Aug 26 20:58 *
    drwxrwxrwx. 13 nobody root 4.0K Aug 26 17:34 ..
    drwxrwxrwx.  2 root   root   14 Aug 26 17:31 .
    

    Well that definitely does not seem to be correct! Did you copy/merge all your files together into one? I’ve tried a couple of different ways to end up with the files being copied to a file named * but I couldn’t figure out how you were able to. Please get your partitions right as Wayne suggested and then copy over the files again.



  • @Wayne-Workman I’ve adjusted the /opt/fog/.fogsettings file to point to /home and removed my fstab entry so I don’t screw up Linux /images any more than I already have :)



  • I’m checking the files you told me to check to make sure the correct path is in them now, though.


  • Moderator

    @Chris-Shipley Ok then. So, I guess it was just a copying issue? I’m not trying to be difficult. Please ask more questions if you need, we’re here to help.



  • OK, I wasn’t picking up what you’re putting down regarding specifically Linux. The FOG server’s storage is on the 177G volume, let’s leave it at that. It does work, it has images I’ve already captured on it and if it weren’t on that volume, there’d be a lot less free space on the 50G volume now. We’re good, though.


  • Moderator

    @Chris-Shipley I don’t think you follow, I’ll explain. /images IS a path, and an absolute path too in Linux terms. When you say “/images points to…” well that statement already says where it is. it means /images, which resides on /, which in your case is limited to 50GB. It’s like me saying my car which is currently in the front yard is in the backyard, or my keyboard which is currently on my desk is not on my desk. My /images are not located at /images makes no sense. Just say images, not /images. because /images is a literal path that literally means /images. /images indeed means /images. What actually is setup might be something else, and might not be /images. And if it is something else, your /etc/exports file needs updated to reflect the true path, your Storage Node’s images path and FTP path needs updated to the true path, and the .mntcheck files and dev folder need made in the true path. And your /opt/fog/.fogsettings file needs updated to reflect the true path.



  • I’ve got this line in my fstab

    /dev/mapper/centos-home /images                 xfs     defaults        0 0
    


  • Thanks for the warning, but that’s not the case. /images does indeed point to the 177G volume here in this implementation. There are about 20GB of data in there, and if you were correct I’d have 30G free on the volume you’re concerned about. We’re good in this sense. I just didn’t check my syntax on the SCP command, which admittedly I rarely use, and pushed all the files into a single filename * when I made the copy command. I’ll update after I get the files in and see if I can get it to work.


  • Moderator

    @Chris-Shipley said in Manually copy image between FOG hosts:

    Nah, /images actually points to the 177 GB volume

    /images means /images, which is limited to 50GB on this new server. Your /etc/exports file indicates this is the location in your first post.

    The 177GB partition is mounted to /home.



  • Nah, /images actually points to the 177 GB volume


  • Moderator

    @Chris-Shipley Also, your partitions are setup wrong. I’m guessing you used Fedora or CentOS, and did not follow one of our tutorials. At present, this server is limited to 50GB worth of images, and when that fills, the server will crash.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.