Re: Snapin Hash does not exist


  • Moderator

    Created a new thread, but it’s more or less a continuation of this thread I think:
    https://forums.fogproject.org/topic/7626/snapin-hash-does-not-exist

    @Tom-Elliott I’m afraid this issue has come up again, but I really don’t think that it’s related to file-size this time.

    A co-worker at another site said his snapins aren’t working. I did some investigating. I got the ERROR: Snapin hash does not exist error when trying to deploy a snapin from his fog server’s storage group. His server is in it’s own group by itself and set as master. But when I try to deploy a snapin from the main fog server it works fine.

    I created a new snapin, Google Chrome MSI, which is 54MB in size and put it on his storage group and I get the same error. I’ve re-ran the installer on his storage node, disabled firewall, rebooted, turned off bandwidth reporting, and I can’t get it to work.

    We are using RC-8 with Client 0.11.5.

    Another thing - this is a recent issue. We’ve been using RC-8 for maybe a week now and this just happened.

    Attached is the client log.
    0_1471899304050_fog.log

    notice how the permissions on the file is fog:fog that’s probably an issue. I checked on the main server too, and looked at permissions there. Seems like snapins that have been created in August have the wrong permissions (fog:fog instead of fog:apache).

    0_1471899267241_upload-30263ab2-9ce5-4569-98ef-35d23b4e8bd2

    0_1471899183888_upload-bc9a40bd-9529-42ff-af0f-ca701a59cfd4


  • Moderator

    @Tom-Elliott I ended up just resetting the fogstorage password and replacing the $ with an s and ran a script to change this on all nodes.

    I can continue to test escaping at home though.


  • Senior Developer

    @Wayne-Workman This issue, as you undoubtedly found now is not something easily fixable.

    The issue was the special character $ as a part of your password.

    I’m having you test a “fix” that should hopefully escape and store the escaped sequences for us as we speak, but I don’t know of a simpler way to escape characters in bash.

    I’m hoping the test fixes this once and for all, but escaping is a bitch.


  • Moderator

    @Tom-Elliott

    When visiting http://x.x.x.x/fog/service/ipxe/boot.php for any of the Storage Nodes, the page returns:

    #!db

    This is the issue.

    I’ve confirmed manually that the fogstorage user/pass works manually from the storage nodes.

    I’ve confirmed the credentials are correct in /opt/fog/.fogsettings

    I’ve confirmed the credentials are correct in /var/www/html/fog/lib/fog/config.class.php

    This leads me to believe that the password itself is causing PHP issues with connecting to the DB.

    I’m testing this theory by changing it to something without special characters.


  • Moderator

    I’ve done a git pull to verify I’m on the latest version of 1.3.0 RC-8, still experiencing the same problem.


  • Moderator

    Setting permissions to chmod -R 775 /opt/fog/snapins and then restarting the fog client also resulted in the exact same error.


  • Moderator

    Just set permissions on the snapins directory with chown -R fog:apache /opt/fog/snapins and restarted the client, no dice…

    ------------------------------------------------------------------------------
    ---------------------------------SnapinClient---------------------------------
    ------------------------------------------------------------------------------
     8/22/2016 3:57 PM Client-Info Client Version: 0.11.5
     8/22/2016 3:57 PM Client-Info Client OS:      Windows
     8/22/2016 3:57 PM Client-Info Server Version: 1.3.0-RC-8
     8/22/2016 3:57 PM Middleware::Response Success
     8/22/2016 3:57 PM SnapinClient Snapin Found:
     8/22/2016 3:57 PM SnapinClient     ID: -1
     8/22/2016 3:57 PM SnapinClient     Name: 
     8/22/2016 3:57 PM SnapinClient     Created: -1
     8/22/2016 3:57 PM SnapinClient     Action: 
     8/22/2016 3:57 PM SnapinClient     Pack: False
     8/22/2016 3:57 PM SnapinClient     Hide: False
     8/22/2016 3:57 PM SnapinClient     Server: 
     8/22/2016 3:57 PM SnapinClient     TimeOut: -1
     8/22/2016 3:57 PM SnapinClient     RunWith: 
     8/22/2016 3:57 PM SnapinClient     RunWithArgs: 
     8/22/2016 3:57 PM SnapinClient     Args: 
     8/22/2016 3:57 PM SnapinClient     File: 
     8/22/2016 3:57 PM SnapinClient ERROR: Snapin hash does not exist
    ------------------------------------------------------------------------------
    

    0_1471899583872_upload-665c9de5-d85b-479e-978b-47c6fa52db5c


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.