Unable to start task, unable to connect to tftp server



  • Hi guys, I was scouring the forum looking for a problem similar to mine and trying out all the solutions. However nothing has seemed to work.

    Whenever I attempt to set FOG to upload an image it tells me “unable to start task, unable to connect to tftp server”. Computers can boot to pxe just fine and I registered the host computer, however this one problem is blocking my path. Any suggestions?


  • Moderator

    If you have modified it from the original, just make up a new one and change all the necessary locations where it is stored, including the user account on the server.



  • ok. Thank you for that chad. how do I come up with the long number like password in the config.php file for TFTP anf FTP storage?


  • Moderator

    The ONLY password in the entire FOG configuration that is encrypted is the password used to join computers to Active Directory. The rest of the passwords may look encrypted, but they are not.

    Do NOT use FOGCrypt to encrypt any passwords other than the Join AD password.



  • I am having an issue like this one. I ama new admin for this place and was not givin any passwords or anything from the previouse guy. i was able to change the default user Fog’s password back to password. Then I used the fog crypt and genererated the password from that. Copied that into the .config.php file under tftp password and storage ftp password. I also changed it in the default storage group, and in the fog settings under tftp password-All to the encrypted version of “password” i am still getting the unable to connect to tftp server error. I would really appreciate any help. School is starting in about a week and I’m running out of time.



  • That was it… Shows in the tutorial not to do this but I was doing it from memory… Hopefully if someone else does this they’ll stumble on this post and immediately figure out that they are wrong :)



  • So here’s to following directions…

    When loading my last two loads I created the Ubuntu system user as “fog” which was causing my problems I think. I’m testing now to see if I can upload… At least the task is started and running! :)



  • So yesterday in an attempt to get this working I reloaded the box with Ubuntu 10.04 LTS and installed FOG under that OS fresh.

    Under this new install I was also able to register the host by booting it up with PXE and then doing a full host registration. I’m still having the same issue though with being unable to start a upload task with the FOG Management console. I tried resetting the password using sudo passwd fog and then resetting it but I’m still having issues starting an upload with the same message as in my previous attachment.

    I’ve also gone into /var/www/fog/commons/config.php and changed the values for TFTP_FTP_PASSWORD and STORAGE_FTP_PASSWORD to match the password for fog with no luck.



  • I finally got it to work by changing the FOG password in terminal. There should be some results for it in the results if you searched this on google. If I remember correctly it’s something like this:

    sudo pssword fog <password>



  • I’m having a similar issue. I’m using Ubuntu 11.10 and have installed FOG 0.32. This is a fresh install. I was able to register a host booting it up from PXE and then performing a full host registration.

    When I select that host from the FOG Management console and try and upload, I get “Unable to start task Unable to connect to tftp server” at that confirm task page.

    [url="/_imported_xf_attachments/0/144_fog issue.png?:"]fog issue.png[/url]


  • Moderator

    How are you registering hosts? Do you get the fog menu and the registration/inventory part to work?



  • Is this a fresh install, if so make sure you change the fog default password, and after doing so enter the new password in the fog settings under tftp password. Also make sure you change the fog user password for the system. sudo passwd fog and enter new password. Also make sure the storage password is set, with the same fog user password you created.


Log in to reply
 

375
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.