FOG Server PXE boot



  • [SIZE=12px][FONT=Arial][COLOR=#333333]all 20 computers PXE boots to FOG with no problems, uploads and deploys images expect 3 computers, all which has newer motherboards (gigabyte), I trying booting with etherboot/gPXE which took me to the fog pxe menu
    That tells me that the fog kernel doesnt support the driver (RTL8111).[/COLOR][/FONT][/SIZE]
    [SIZE=12px][FONT=Arial][COLOR=#333333]Tried several kernels, still the same
    anything I can do?

    Thanks [/COLOR][/FONT][/SIZE]



  • Im really glad there is someone to help me with this situation, Ive been trying to compile a kernel with my driver for the past week and cant accomplish it!.. everytime I go in the “make xconfig” i cant see my driver even though iv done almost everything to make sure it is in the directory
    Im trying with the 3.4 now


  • Moderator

    Hi Shaker, welcome to the forums!

    It sounds like the integrated NIC on 3 of your newer motherboards are not compatible with the Fog kernels you are trying to use. Have you tried any of the 3.3 or 3.4 kernels?

    The RTL8111 seems to use the same linux drivers as the RTL8168, and have been around since 2008, so a kernel somewhere should support them.

    If not, you can customize your kernel for Fog by using steps similar to those I followed and documented in: [url]http://fogproject.org/forum/threads/compiling-a-custom-kernel-for-acer-iconia-tab-copied-from-old-forums.216/[/url]

    If the configurator already has a section for the RTL8111 or RTL8168, then it’s as easy as overwriting the files in the source tree and recompiling the kernel.


Log in to reply
 

366
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.