Changing DHCP settings



  • I ran into a problem I am not sure how to correct. When I initially set up fog I was using a router as the DHCP server but thought I may decide to change that at some point. As such I set FOG as a DHCP server but I didn’t put in a router or DNS address. I then turned DHCP off on the router and am allowing FOG to take over as DHCP server now. Everything was working except since it didn’t have a router or dns assigned it was not assigning the hosts a gateway or DNS. I found where to fix this in /etc/dhcp/dhcpd.conf and when I make the changes it now properly assigns Gateway and DNS to the hosts, but then the hosts can no longer boot to PXE, it gives a Timeout Error.

    What do I need to do to make changes to the DHCP server, and not affect the TFTP PXE boot?


  • Moderator

    When you installed Fog, it asked if you wanted to setup Fog as your DHCP server, and it configures it properly if you say YES. But you said NO, and it prompted you with instructions on how to update your existing DHCP server to modify options 66 and 67 (windows) or next-server and filename (linux). You must have missed these helper notes.

    I think all you need to do is update your dhcpd.conf with the next-server and filename options for the scope definition. See: [url]http://www.fogproject.org/wiki/index.php/Modifying_existing_DHCP_server_to_work_with_FOG[/url]

    Let me know if this helps. You may want to post your dhcpd.conf file (use code tags when posting to boards).



  • next-server and filename? no.

    Basically all I did was install FOG but left out the router IP and DNS during the installation (I thought it would be easy to change these settings later). After it was installed and working, I reconfigured the router; I just turned off DHCP and did nothing else.

    At that point FOG was still working properly, but the client computers were not receiving a default gateway or DNS (as expected). I then made the modifications to /etc/dhcp/dhcpd.conf which does correct the Gateway/DNS issue, however, after making that change I’m then unable to boot to PXE. I just get timeouts even though it does the server and get assigned an IP. Even when I go back to the /etc/dhcp/dhcpd.conf and revert the changes I made, PXE still does not boot.

    My theory is that the method I use to make the changes is somehow affecting permissions or something. I simply give myself su permissions from terminal and open up the text editor (pluma was the default in MINT), then open the file, save changes, and close. It would be nice if the DHCP server settings were built into the FOG Settings config page but I couldn’t find any such area.


  • Moderator

    Did you set the next-server and filename options in DHCP?


Log in to reply
 

387
Online

38937
Users

10696
Topics

101490
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.