Multicast won't start



  • Hey guys,
    I’m trying multicast and nothing will work. All the laptops are stuck on the partclone screen and nothing start.

    0_1470685331481_Partclone.jpg

    Setup :
    Ubuntu 14.04.5 LTS
    Running Version 1.3.0-RC-7
    SVN Revision: 5946

    any idea?


  • Moderator

    @Towndrunk said in Multicast won't start:

    Is there any benefit to updating all the time if there is also the potential to have things not work?

    The benefit - getting a bug you report fixed. Getting bug fixes others report.

    Updating is totally up to you. Nobody is forcing your hand, and Release candidates are just that. Release candidates. If you want to sit on it, you can. If you want to update, you can.

    However - if you have issues and ask for help here, and the devs/mods/testers know your issue is fixed in a later RC, we will ask you to update and won’t offer much help with getting your older RC to work, when all you would need to do is update. Of course we’d help with the updating itself if you had problems. But it’s all still up to you.



  • I applied the most recent update, and I am now able to register and multicast again.

    Is there any benefit to updating all the time if there is also the potential to have things not work? Maybe I will just leave it how it is for now until our computer roll out is done.


  • Moderator

    @Towndrunk There were multicast and registration issues in rc8 and 9, and 10 fixes these.

    What version are you on now?



  • @Wayne-Workman was able to do some testing, and after forcing it to use port 9000, we could get it to work. For some reason over the last few days it has now stopped working. I’m not sure if it has something to do with an update or not? We have made no changes to the network, and it was working while imaging the last 100 computers are so. We have just been using the deploy option, but with multiple computers at the same time it can cause a lot of latency on the network.

    We have been working through it, however for some reason we can’t register hosts now either. Every time I go in and register a host it shows up in Host Management, but it is named the MAC Address and isn’t assigning the image or the group. I’m going to perform another update now since it shows that I’m out of date and try it again.


  • Moderator

    @Towndrunk Would you mind doing a TeamViewer session with me? Message me if you’re interested.



  • @Wayne-Workman it isn’t working. The thing is, that once I set it up on the server by using the information on the troubleshooting page I get this information.

    Udp-sender 20120424
    Using full duplex mode
    Using mcast address 234.15.31.20
    UDP sender for /opt/fog.fogsettings at 10.15.31.20 on eth0
    Broadcasting control to 10.15.31.255

    Why is the mcast address 234.15.30.20 when the IP of my server is 10.15.31.20? The server and the test device aren’t talking at all right now.


  • Moderator

    @Towndrunk said in Multicast won't start:

    I do not have another Linux machine running at this time to perform the test.

    Do a debug-deploy with fog, and you have made a linux console out of whatever computer you want. Debug is an option on the confirmation page for any FOS task.



  • @Wayne-Workman the settings for the network are correct in the Interface setting for the Storage Management. I do not have another Linux machine running at this time to perform the test. I will have to get a live-boot going and perform the test. I’ll let you know the results once I’m done.


  • Moderator

    @Towndrunk Can you read through this article please?
    https://wiki.fogproject.org/wiki/index.php?title=Troubleshoot_Downloading_-_Multicast

    And, after you’re done reading through it, please just go over the settings it mentions. If all those look good, try the test in that article.



  • @Wayne-Workman I made a group called Multicast and added one computer to that group. I sent a multicast to that computer, and powered it on. It comes to the same screen as it has in the past, and sits there. It doesn’t appear to be doing anything, and I’m not sure how to interpret what the logs say it is doing. . . It just continues to post the “Task (4) Multi-Cast Task is already running PID 28433”

    [08-11-16 1:38:33 pm] * No tasks found!
    [08-11-16 1:38:43 pm] * No tasks found!
    [08-11-16 1:38:53 pm] | Task (4) Multi-Cast Task is new!
    [08-11-16 1:38:53 pm] | Task (4) Multi-Cast Task has been cleaned.
    [08-11-16 1:38:53 pm] | Task (4) /images/Windows10DefaultLaptop image file found.
    [08-11-16 1:38:53 pm] | Task (4) 1 client(s) found or to receive.
    [08-11-16 1:38:53 pm] | Task (4) Multi-Cast Task sending on base port: 56436
    [08-11-16 1:38:53 pm] | CMD: cat /images/Windows10DefaultLaptop/d1p1.img | /usr/local/sbin/udp-sender --interface eth0 --min-receivers 1 --max-wait 600 --portbase 56436 --full-duplex --ttl 32 --nokbd --nopointopoint;cat /images/Windows10DefaultLaptop/d1p2.img | /usr/local/sbin/udp-sender --interface eth0 --min-receivers 1 --max-wait 10 --portbase 56436 --full-duplex --ttl 32 --nokbd --nopointopoint;cat /images/Windows10DefaultLaptop/d1p3.img | /usr/local/sbin/udp-sender --interface eth0 --min-receivers 1 --max-wait 10 --portbase 56436 --full-duplex --ttl 32 --nokbd --nopointopoint;cat /images/Windows10DefaultLaptop/d1p4.img | /usr/local/sbin/udp-sender --interface eth0 --min-receivers 1 --max-wait 10 --portbase 56436 --full-duplex --ttl 32 --nokbd --nopointopoint;cat /images/Windows10DefaultLaptop/d1p5.img | /usr/local/sbin/udp-sender --interface eth0 --min-receivers 1 --max-wait 10 --portbase 56436 --full-duplex --ttl 32 --nokbd --nopointopoint;
    [08-11-16 1:38:53 pm] | Task (4) Multi-Cast Task has started.
    [08-11-16 1:39:03 pm] | Task (4) Multi-Cast Task is already running PID 28433
    [08-11-16 1:39:13 pm] | Task (4) Multi-Cast Task is already running PID 28433
    [08-11-16 1:39:23 pm] | Task (4) Multi-Cast Task is already running PID 28433
    [08-11-16 1:39:33 pm] | Task (4) Multi-Cast Task is already running PID 28433
    [08-11-16 1:39:43 pm] | Task (4) Multi-Cast Task is already running PID 28433
    [08-11-16 1:39:53 pm] | Task (4) Multi-Cast Task is already running PID 28433
    [08-11-16 1:40:03 pm] | Task (4) Multi-Cast Task is already running PID 28433
    [08-11-16 1:40:13 pm] | Task (4) Multi-Cast Task is already running PID 28433
    [08-11-16 1:40:23 pm] | Task (4) Multi-Cast Task is already running PID 28433
    [08-11-16 1:40:33 pm] | Task (4) Multi-Cast Task is already running PID 28433
    [08-11-16 1:40:43 pm] | Task (4) Multi-Cast Task is already running PID 28433
    [08-11-16 1:40:53 pm] | Task (4) Multi-Cast Task is already running PID 28433
    [08-11-16 1:41:03 pm] | Task (4) Multi-Cast Task is already running PID 28433
    [08-11-16 1:41:13 pm] | Task (4) Multi-Cast Task is already running PID 28433
    

  • Moderator

    @Towndrunk Try to multicast to a group with just one host in it. Use groups to create the multicast task. See what happens. At this point, I just want to see if multicast is working at all.



  • @Towndrunk
    There is a setting under the header Multicast Settings that is called FOG_UDPCAST_MAXWAIT you might look there to see if that is where you set the 10 minute timeout.



  • @Wayne-Workman @Tom-Elliott Just wanted to thank you guys, great support for a great product!



  • Is there a limit on how long you have to join the Multicast? I just tried another test and set it up for timeout of 10 minutes. I was able to get the first one added, however once I went to the second one it was not able to find the Session I created.

    The odd thing is that if I send an image to any of these the individually I have no issues at all. I just assumed that the Multicast would be quicker if we were doing a group all at once. If I have to, I can just go back to doing them individually.



  • Now, once the Multisession is started the first computer will join and sit on the same screen as it always has, but now the second computer will not connect. It does all of the checks, but then Attempts to check in and fails. . .

    • Attempting to check in…Failed
    • Invalid Multicast Session ( In line for )
    • Attempting to check in…Failed
    • Invalid Multicast Session ( In line 5)
    • Attempting to check in…Failed
    • Invalid Multicast Session ( In line 10)
    • Attempting to check in…Failed
    • Invalid Multicast Session ( In line 15)
    • Attempting to check in…Failed
    • Invalid Multicast Session ( In line 20)

    I tried this process two times, with four different laptops.

    [08-11-16 10:37:33 am] * No tasks found!
    [08-11-16 10:37:43 am] * No tasks found!
    [08-11-16 10:37:53 am] | Task (1) laptop is new!
    [08-11-16 10:37:53 am] | Task (1) laptop has been cleaned.
    [08-11-16 10:37:53 am] | Task (1) /images/Windows10DefaultLaptop image file found.
    [08-11-16 10:37:53 am] | Task (1) 2 client(s) found or to receive.
    [08-11-16 10:37:53 am] | Task (1) laptop sending on base port: 51300
    [08-11-16 10:37:53 am] | CMD: cat /images/Windows10DefaultLaptop/d1p1.img | /usr/local/sbin/udp-sender --interface eth0 --min-receivers 2 --max-wait 240 --portbase 51300 --full-duplex --ttl 32 --nokbd --nopointopoint;cat /images/Windows10DefaultLaptop/d1p2.img | /usr/local/sbin/udp-sender --interface eth0 --min-receivers 2 --max-wait 10 --portbase 51300 --full-duplex --ttl 32 --nokbd --nopointopoint;cat /images/Windows10DefaultLaptop/d1p3.img | /usr/local/sbin/udp-sender --interface eth0 --min-receivers 2 --max-wait 10 --portbase 51300 --full-duplex --ttl 32 --nokbd --nopointopoint;cat /images/Windows10DefaultLaptop/d1p4.img | /usr/local/sbin/udp-sender --interface eth0 --min-receivers 2 --max-wait 10 --portbase 51300 --full-duplex --ttl 32 --nokbd --nopointopoint;cat /images/Windows10DefaultLaptop/d1p5.img | /usr/local/sbin/udp-sender --interface eth0 --min-receivers 2 --max-wait 10 --portbase 51300 --full-duplex --ttl 32 --nokbd --nopointopoint;
    [08-11-16 10:37:53 am] | Task (1) laptop has started.
    [08-11-16 10:38:03 am] | Task (1) laptop is already running PID 27846
    [08-11-16 10:38:13 am] | 1 task to be cleaned
    [08-11-16 10:38:13 am] | Cleaning 1 task(s) removed from FOG Database.
    [08-11-16 10:38:13 am] | Cleaning Task (1) laptop
    [08-11-16 10:38:13 am] | Task (1) laptop has been completed.
    [08-11-16 10:38:13 am] * No tasks found!
    [08-11-16 10:38:23 am] * No tasks found!
    [08-11-16 10:38:33 am] * No tasks found!
    [08-11-16 10:38:43 am] * No tasks found!
    [08-11-16 10:38:53 am] * No tasks found!
    [08-11-16 10:39:03 am] * No tasks found!
    [08-11-16 10:39:13 am] * No tasks found!
    [08-11-16 10:39:23 am] * No tasks found!
    [08-11-16 10:39:33 am] | Task (2) blabla is new!
    [08-11-16 10:39:33 am] | Task (2) blabla has been cleaned.
    [08-11-16 10:39:33 am] | Task (2) /images/Windows10DefaultLaptop image file found.
    [08-11-16 10:39:33 am] | Task (2) 2 client(s) found or to receive.
    [08-11-16 10:39:33 am] | Task (2) blabla sending on base port: 57034
    [08-11-16 10:39:33 am] | CMD: cat /images/Windows10DefaultLaptop/d1p1.img | /usr/local/sbin/udp-sender --interface eth0 --min-receivers 2 --max-wait 240 --portbase 57034 --full-duplex --ttl 32 --nokbd --nopointopoint;cat /images/Windows10DefaultLaptop/d1p2.img | /usr/local/sbin/udp-sender --interface eth0 --min-receivers 2 --max-wait 10 --portbase 57034 --full-duplex --ttl 32 --nokbd --nopointopoint;cat /images/Windows10DefaultLaptop/d1p3.img | /usr/local/sbin/udp-sender --interface eth0 --min-receivers 2 --max-wait 10 --portbase 57034 --full-duplex --ttl 32 --nokbd --nopointopoint;cat /images/Windows10DefaultLaptop/d1p4.img | /usr/local/sbin/udp-sender --interface eth0 --min-receivers 2 --max-wait 10 --portbase 57034 --full-duplex --ttl 32 --nokbd --nopointopoint;cat /images/Windows10DefaultLaptop/d1p5.img | /usr/local/sbin/udp-sender --interface eth0 --min-receivers 2 --max-wait 10 --portbase 57034 --full-duplex --ttl 32 --nokbd --nopointopoint;
    [08-11-16 10:39:33 am] | Task (2) blabla has started.
    [08-11-16 10:39:43 am] | Task (2) blabla is already running PID 27920
    [08-11-16 10:39:53 am] | Task (2) blabla is already running PID 27920
    [08-11-16 10:40:03 am] | Task (2) blabla is already running PID 27920
    [08-11-16 10:40:13 am] | Task (2) blabla is already running PID 27920
    [08-11-16 10:40:23 am] | Task (2) blabla is already running PID 27920
    [08-11-16 10:40:33 am] | Task (2) blabla is already running PID 27920
    [08-11-16 10:40:43 am] | 1 task to be cleaned
    [08-11-16 10:40:43 am] | Cleaning 1 task(s) removed from FOG Database.
    [08-11-16 10:40:43 am] | Cleaning Task (2) blabla
    [08-11-16 10:40:43 am] | Task (2) blabla has been completed.
    [08-11-16 10:40:43 am] * No tasks found!
    [08-11-16 10:40:53 am] * No tasks found!
    


  • @BedCruncher I’ll make an attempt now and see what happens.

    root@FogServer:~# sudo service FOGMulticastManager stop
     * Stopping FOG Computer Imaging Solution: FOGMulticastManager                                                                 [ OK ] 
    root@FogServer:~# killall udp-sender
    root@FogServer:~# killall udp-sender
    root@FogServer:~# killall udp-sender
    root@FogServer:~# mysql -u root fog
    Reading table information for completion of table and column names
    You can turn off this feature to get a quicker startup with -A
    
    Welcome to the MySQL monitor.  Commands end with ; or \g.
    Your MySQL connection id is 107
    Server version: 5.5.50-0ubuntu0.14.04.1 (Ubuntu)
    
    Copyright (c) 2000, 2016, Oracle and/or its affiliates. All rights reserved.
    
    Oracle is a registered trademark of Oracle Corporation and/or its
    affiliates. Other names may be trademarks of their respective
    owners.
    
    Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.
    
    mysql> TRUNCATE TABLE multicastSessionsAssoc;
    Query OK, 0 rows affected (0.00 sec)
    
    mysql> TRUNCATE TABLE multicastSessions;
    Query OK, 0 rows affected (0.00 sec)
    
    mysql> TRUNCATE TABLE tasks;
    Query OK, 0 rows affected (0.00 sec)
    
    mysql> quit;
    Bye
    root@FogServer:~# sudo service FOGMulticastManager start
     * Starting FOG Computer Imaging Solution: FOGMulticastManager                                                                 [ OK ]
    


  • @Towndrunk
    Try this…

    systemctl stop FOGMulticastManager
    killall udp-sender
    killall udp-sender
    killall udp-sender
    mysql -u root fog
    TRUNCATE TABLE multicastSessionsAssoc;
    TRUNCATE TABLE multicastSessions;
    TRUNCATE TABLE tasks;
    quit;
    systemctl start FOGMulticastManager
    


  • @Wayne-Workman Ubuntu 14.04 LTS

    mysql> DELETE FROM `multicastSessions` WHERE 1;
    Query OK, 1 row affected (0.00 sec)
    
    mysql> DELETE FROM `multicastSessionsAssoc` WHERE 1;
    Query OK, 0 rows affected (0.00 sec)
    
    mysql> DELETE FROM `tasks` WHERE `taskTypeID` = 8;
    Query OK, 2 rows affected (0.00 sec)
    
    mysql> quit
    Bye
    root@FogServer:~# cd /root/fogproject
    root@FogServer:~/fogproject# git pull
    Already up-to-date.
    root@FogServer:~/fogproject#
    

  • Moderator

    @Towndrunk No, don’t bother then.

    What OS is fog running on?



  • @Wayne-Workman I can do that. I am already running RC-8 though. I ran the upgrade this morning before doing the steps to clean the DB. If you want me to, I can repeat the process now.

    Running Version 1.3.0-RC-8
    SVN Revision: 5949


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.