iPXE and Reboot Restore Rx™



  • Folks - I am trying to use Reboot Restore Rx™ (a software product that rolls back any hard drive changes upon reboot) with fog and I am not able to get it to boot after the PXE boot hands things over to the hard drive. I tried every Host Bios Exit Type listed but Reboot Restore Rx always errors out. When I set the PC’s to boot from the hard drive, it works as it should. Does anybody have any experience with this product or similar?

    Thanks!



  • @george1421 - thanks for your help. The problem with RRRx is it’s freeware, and I would suspect that the company that makes it is not interested in supporting it unless you buy a copy (or 100 in my case). I have been testing it for several days now and it seems to perform quite well and I would bet it would be more reliable then what we had been using, Fortres Grand’s Clean Slate. The only problem is you have to install it at the first boot after the sysprep stuff finishes, and it does not include a silent install option. Again, it’s freeware and the company says it’s not supposed to have any bells and whistles. Fortunately, there is an AutoIT script that can install it hands off, so I intend to put that at the end of my post install script and see where that takes us.

    Thanks again!


  • Moderator

    @LibraryMark said in iPXE and Reboot Restore Rx™:

    Is this file (ipxe.kpxe) updated from time to time? And what’s the difference between it and ipxe.kkpxe?

    The short answer is yes. Each time the FOG image is rebuilt (by the developers) the latest version of iPXE files are updated. So if you just updated to RC7 then you would have the latest build of iPXE.

    That’s strange that changing the ipxe file from .kkpxe to kpxe would impact the exit modes. But if you have it working and the .kpxe file works for all systems then take the win and move on to the next issue.

    Great job, because from the research I did so far this was going to be an interesting time to find a fix.



  • OK - here’s a wrinkle - I have normally used ipxe.kkpxe because I have some realtek nics that won’t boot to ipxe.kpxe. This morning after once again testing all the possible exit choices on a lark I thought I would try ipxe.kpxe and it seemed to boot all of my machines and did allow RRRx to work on the test machine.

    Is this file (ipxe.kpxe) updated from time to time? And what’s the difference between it and ipxe.kkpxe?



  • @george1421
    I did say that I am on the trunk version, current as of yesterday morning. Version 1.3.0-RC-7
    SVN Revision: 5946


  • Moderator

    @LibraryMark As far as I can tell this software has a preboot environment that resets the windows environment back to a baseline state. Its probably using some kind of linux based boot environment. If we can find out how to chain load into that environment I’m sure we can get grub to connect to the right device. I did reach out to a Horizon DataSys rep to see if we can learn what is needed to chain boot from the iPXE menu.

    Also I don’t think you answered what version of FOG are you running AND you mentioned that RR errors out. For completeness would it be possible for you to post a screen shot (a clear shot with a mobile phone will work) of the actual error. The error may provide some insight into what went wrong. If the errors are different between sanboot and grub, then please post them.

    tech reference:
    for exit of sanboot fog is using
    sanboot --no-describe --drive 0x80

    for exit of grub fog is using
    chain -ar ${boot-url}/service/ipxe/grub.exe --config-file=“rootnoverify (hd0);chainloader +1”



  • I tried every exit type, including sanboot, grub and grub_first_hdd.

    I do need PXE boot first, as I image as many as 40 machines (sometimes in another building) at a time - I would rather not have to go to each machine and hit f12.


  • Moderator

    @LibraryMark OK I think I have enough info (except for the mbr question). I’m looking into the iPXE exit modes.

    So just for clarity you went into one specific target host and tested under bios exit types
    sanboot
    grub
    grub_first_hdd

    (the rest are probably not relevant)

    I do have to ask you if you need FOG to be first in your boot order? If you need unattended reimaging then yes. If you will have a IT tech reimage the machine under IT Tech control then you might want to change your boot order to the hard drive and then only enter pxe boot through the F12 boot menu. Not saying this is mandatory just yet, just one possible way.



  • george1421 - Thanks for your reply. I will try to answer your questions the best I can.

    The target machines are bios-based
    I am using the latest trunk (as of this morning)
    I do not know if reboot-restore created it’s own MBR. How do I look for that?
    I do deploy these machines with fog.
    The reference machine does not have RR installed. I install it after the machines are imaged. If it was installed on the image the hostname changer would not work.

    When I escape out of PXE boot, RR does it’s job. When I let the PXE menu load and then try to boot the hard drive, RR errors out.


  • Moderator

    Sorry no experience with this software.

    I do have a few questions

    1. Are the target computers bios(legacy) or uefi based?
    2. What version of FOG are you using?
    3. Do you know if reboot restore creates their own master boot record?
    4. When you setup these systems, did you deploy them with fog?
      4a. If Yes, did the target reference image have this reboot restore software already installed?

    I’m just trying to establish a baseline of information.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.