[1.3.0-RC-5] Login history report shows blank page



  • I am getting a blank page whenever I run the Login History report. Steps to reproduce:

    1. Go to ‘Report Management’ and select ‘Login History’.
    2. Choose any value from the username and hostname select lists.
    3. Click ‘Search’.

    After doing this, the page turns blank (i.e. completely white) and nothing happens. I see no errors on the page or in the browser console. I am using Firefox 47 on Ubuntu 14.04.



  • @Tom-Elliott Apologies for taking so long to make this reply.

    The login history report now runs, but it is not giving any useful information. Steps to replicate (this is using rc8):

    1. Go to Report Manager > Login History
    2. Enter username and hostname, then click ‘Search’.
    3. Things start to get weird here. A table appears with two columns: one labeled ‘Host/User name’; the second labeled ‘Username’. The first column is filled with the hostname entered in step 2, while the second column is empty.
    4. Click on the first instance of the hostname in the ‘Host/User name’ column.
    5. Enter a date range and click ‘Search’.
    6. At this point I get a message saying ‘No results found’. I get this regardless of what date range I choose.

    Now, if I go to Host Management > List all hosts > hostname > Login History, then the report DOES show the correct history for any date I choose.


  • Senior Developer

    @Brian-David Apparently no, it didn’t make it. It probably got missed due to trying to fix other issues. I have re-fixed this and will be in RC-7 which I expect to be pushed out this weekend.



  • @Tom-Elliott Did this make it into rc-6? I upgraded today, and while the line 23 error seems to be gone, the login history report still does not work. I’m getting the exact same error in the Apache logs.


  • Senior Developer

    I’ll add that the line 23 error has already been addressed from earlier report today.


  • Senior Developer

    @Brian-David Awesome. I found it and fixed it. Sorry it won’t be ready right away, as we’re on RC cycles, I only push to a working branch.



  • This is the relevant log entry:

    [Mon Aug 01 17:17:35.354209 2016] [:error] [pid 1741] [client xxx.xxx.xxx.xxx:42719] PHP Fatal error: Call to a member function get() on null in /var/www/html/fog/lib/pages/reportmanagementpage.class.php on line 737, referer: http://fog/fog/management/index.php?node=report&sub=user-track

    On a side note, my error log is also getting spammed with this message:

    [Mon Aug 01 17:20:12.018555 2016] [:error] [pid 5562] [client xxx.xxx.xxx.xxx:52967] PHP Strict Standards: Only variables should be assigned by reference in /var/www/html/fog/lib/fog/fogmanagercontroller.class.php on line 23


  • Senior Developer

    What’s in your Apache error logs?


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.