Windows 10 image won't deploy



  • I uploaded a Windows 10 image this morning using Fog 1.2.0 on Ubuntu 12.04. When I try to push that image out to a new host, I get into a loop. I register the host, tell it to image the host, everything appears fine and then the host shuts down and boots into the Fog menu again. I’ll select Quick Image, it acts like it’s going to start imaging and then shuts down and boots into the Fog menu again.

    Any ideas?


  • Moderator

    @PageTown I know it was a long path to get to this point, BUT know in your heart you are in a better place for the pain you went through. (just channeling Dr. Phil).

    You are on a current and supported release of the your OS and for FOG. When 1.3.0 stable is finally released you will be on a solid platform that you can use for a few years.



  • @Wayne-Workman

    Turns out the problem was that the HDD on the host I was trying to image was too small. After I replaced it with a larger one, I successfully deployed a Windows 10 image, yay!!!

    Thanks for everyone’s help on this!!


  • Moderator

    @PageTown Kudos for moving to 14. We’d never recommend anyone use something as old as Ubuntu 12.

    Can you get a photo of the error that appears in the actual partclone window? It’s just above the stuff in the picture you posted. It may help getting a picture to do a debug deploy. This is a checkbox on the deploy confirmation page. The target computer will boot to a shell. When that’s up, hit enter twice and then type fog and hit enter. You’ll have to press [enter] for every step.



  • So I went with Ubuntu 14.04 and Trunk and set up a new Fog server. I uploaded my Win 10 image. When I tried to deploy it I got further than I did the fist time, but this happened:

    0_1470256644317_Failed03.jpg


  • Moderator

    @Wayne-Workman While I agree with your conclusion, is there any chance we can get a tarball of the install files so git and/or svn isn’t needed? I understand with a moving target such as the trunk builds it would be very hard to maintain yet another repository item. But this could be one solution. But again the right answer is if this system is going to be setup from scratch why not use an OS that will be supported for the useful life of the system you are building.


  • Moderator

    So, I couldn’t install ssh onto Ubuntu 12 Server x64. I spent some time trying, did a lot of research, couldn’t do it. Then I tried updating everything and trying again, no luck.

    So, I said screw it, I’ll just pound it all in at the server. Right around that time, I found out I could not install git nor svn nor subversion.

    At that point, the VM got deleted. :-/
    Not worth a Tuesday evening.

    Move to Ubuntu 14 or 16 please.


  • Moderator

    I downloaded Ubuntu 12 Server x64 and am installing it on a VM right now.

    I’m only doing this because I thought it’d be fun lol.

    It always takes me a minute to use the basic interface in the server edition of Ubuntu to setup volume groups and partitions, and to ensure there’s a separated /images partition.

    I’ll see how the trunk install goes after it’s installed.


  • Moderator

    @PageTown hopefully Wayne has the work around. I know that others have installed the trunk version on 12.04. But just not sure of the process.



  • @george1421 I was REALLY hoping to avoid this. :(


  • Moderator

    @Quazz While this sounds bad and a long path to follow. The OP should install a new FOG server (1.3.0-rcX) on a currently supported OS like Ubuntu 14.04 or 16.04. I can say for sure that FOG 1.3.0-rcX installs flawlessly on Ubuntu 14.04. There are a few small issues install on Ubuntu 16.04 but either would be a good choice.

    Just for clarity end of life (i.e. no more fixes and security patches released) for 12.04 is Apr 2017, 14.04 is Apr 2019, and 16.04 is Apr 2021. Hopefully the developers will have FOG 2.0 released by the time 14.04 LTS goes EOL.


  • Moderator

    @PageTown I believe this issue is due to the fact that there’s an older apache version shipped with ubuntu 12.04

    If I’m not mistaken @Wayne-Workman posted a workaround for it some time ago



  • @jburleson apache2 is installed. I ran sudo apt-get update && sudo apt-get upgrade and then tried sudo apt-get install libapache2-mod-php5 again but got the same result.



  • @PageTown Is apache2 already installed? If so, have you installed all the updates for the server?

    sudo apt-get update && sudo apt-get upgrade



  • @Quazz This:

    0_1470166146058_Failed02.JPG


  • Moderator

    @PageTown What happens when you do

    sudo apt-get install libapache2-mod-php5
    

    ?



  • Here’s is where I am at now. Everything seemed to update well, but the last line. What do I need to do about this?

    0_1470162981188_Failed01.JPG



  • @george1421

    Thanks for catching that! I had scrolled down too far in the wiki.


  • Moderator

    @PageTown Well I’m not a ubuntu guy but I might try to put that all on the same line without the -i

    sudo git clone http...

    But just a comment, you where having an issue with subversion (svn) but now you are using git to collect the installer files. git and svn are two competing programs, but do the same things using different protocols.



  • @george1421

    Can you tell me what the correct command to enter is?

    Here’s what the Upgrade to trunk wiki is telling me to do:

    0_1470154180482_Sudo-iGit.jpg


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.