pxe boot going to wrong ip for tftp server



  • I am a bit of a novice when it comes to linux but I can read and I know how to use google so I figure most things out in time.

    I have been trying to resurrect a fog server that we had run on a project about a year ago and am having a problem I can’t work out.

    The pxe boot process is mostly working, but it get’s to a point where it’s about to download the boot file off the tftp server and the IP it’s trying to connect to is for the gateway, not the server hosting fog and running tftp.

    screenshot of wrong IP

    I’m sure this is something simple, but I just can’t seem to find the answer.

    Anyone out there with a bit of assistance for me?

    Much thanks in advance.


  • Moderator

    @ixll Just be aware I’m not a dnsmasq specialist. I did write my own tutorial on how I setup dnsmasq. This did work. Maybe you can merge what is in your ltsp.conf with this. https://forums.fogproject.org/topic/6376/install-dnsmasq-on-centos-7

    In my example the fog server IP goes into two places.



  • @george1421 said in pxe boot going to wrong ip for tftp server:

    @george1421 OK, while you deleted your post (and put it back) it does tell me what I needed to know.

    if you are using dnsmasq, then you need to look in /etc/dnsmasq.d in (typically) ltsp.conf Make sure the tftp servers there have what you need.

    Once you get dnsmasq fixed then YOU SHOULD upgrade to the latest release of FOG (which is FOG 1.3.0-rc4). You will need the fixes between 4384 and 8600(sum).

    And since you are on the trunk build, then look at the storage node settings that will list the tftp server there too.

    Sorry to confuse with deleting and reposting, not familiar with how this forum formats things and I thought I posted wrong the first time. :D

    Looking at ltsp.conf, the only line I see that has any IP entered into it is “dhcp-range=10.2.36.2, proxy” which the conf file says putting any ip in will do, using your servers IP is what most do.

    Where do I find the storage node settings?

    Thanks


  • Moderator

    @george1421 OK, while you deleted your post (and put it back) it does tell me what I needed to know.

    if you are using dnsmasq, then you need to look in /etc/dnsmasq.d in (typically) ltsp.conf Make sure the tftp servers there have what you need.

    Once you get dnsmasq fixed then YOU SHOULD upgrade to the latest release of FOG (which is FOG 1.3.0-rc4). You will need the fixes between 4384 and 8600(sum).

    And since you are on the trunk build, then look at the storage node settings that will list the tftp server there too.



  • @george1421

    I am using dnsmasq as the router I have does not allow options 66 or 67 to be configured.

    The fog version that is displayed when I log into the web portal is 4384 and the OS is Ubuntu 14.04.3

    As for the settings, I assume you are talking /opt/fog/.fogsettings? I don’t see an option for tftp ip address in that file.



  • This post is deleted!

  • Moderator

    For your network please look at dhcp options 66 and 67 to make sure they are set correctly.

    In the fog configuration settings there is also a setting for tftp server ensure this is pointing to your fog server.

    Since you are reviving an existing fog server, what version is this fog server?


Log in to reply
 

425
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.