• I’m now having issues with the /image storage.

    I put an additional 500GB drive into the system and mounted the drive under /images/EXT

    When changing the default storage node path it seems permissions need to be updated to allow FOG to use the new drive. I keep getting permissions errors. When looking at what the /images/ folder is its set to user #777 which doesn’t seem to exist. Do you guys have a way of doing this? I’m sure it’s pretty easy and I’m just missing something.

  • @Tom-Elliott

    Okay. That fixed it. I had already modified what you told me to type. I just never did the /etc/exports. Once I did that it all worked. 🙂

    Thank you!

  • Senior Developer

    Dude, I missed the EXT part.


    sudo chmod -R 777 /images/EXT
    sudo mkdir /images/EXT/dev
    sudo touch /images/EXT/.mntcheck
    sudo touch /images/EXT/dev/.mntcheck
    sudo chmod -R 777 /images
    sudo chown -R fog:root /images/EXT

    Edit the /etc/exports file to change the path and restart the NFS Server once the file is saved.

  • After running those commands I’m still getting Permission Denied.

    What I currently have is 2 Physical Drives. I have the /images under the main which only has 50GB of space and isn’t able to hold more than 1 image.

    The other drive I used

    mount --bind /media/EXT /images/EXT

    I updated the Storage node to reflect /images/EXT and doesn’t seem to be working. Although after running those commands it updated the /images folder to something else so I’m not sure if that folder works now either. The password in the storage node is correct.

  • Moderator

    You also need to update /opt/fog/.fogsettings images path if I’m not mistaken. Assuming you want this to be your default image storage location and what not.

  • Senior Developer

    sudo chmod -R 777 /images
    sudo chown -R fog:root /images
    sudo mkdir /images/dev
    sudo touch /images/.mntcheck
    sudo touch /images/dev/.mntcheck
    sudo chmod -R 777 /images