Sql Error



  • Your database connection appears to be invalid. FOG is unable to communicate with the database. There are many reasons why this could be the case. Please check your credentials in /var/www/html/fog/lib/fog/config.class.php. Also confirm that the database is indeed running. If credentials are correct, and the Database service is running, check to ensure your filesystem has enough space.

    Is the error i get when i attempt to update the schema. ive tried the steps here and no go.

    what am i doing wrong?

    i am running ubuntu 16:04 cant access schema update or nothing



  • @Wayne-Workman Ok.

    That what i did and then i re-ran the installer and it worked. Thank You!!


  • Moderator

    These are the only two alterations necessary for installing FOG Trunk on a clean build of Ubuntu 16.

    • When you are ready, run the installer with php_ver='7.0' php_verAdds='-7.0' ./installfog.sh
    • When the installer asks you to update the database, there’s 1 extra step. (in another SSH session) Go to mysql and modify the password setting with ALTER USER 'root'@'localhost' IDENTIFIED WITH mysql_native_password BY '';
    • Then you go to the web interface and update the DB as normal, come back to the installer and complete it as usual.


  • Yeah, I ran the new update wizard for fog off the wiki and it starts up just fine.

    really weird, so weird, i dont even know how to explain what occured or how it got fixed.

    I do think it had something to do with space as i ran this command “rm -rf /home/*.BACKUP” as root so i could clear up space. so im gonna upgrage to a bigger drive like 2 or 3 tb that should do.

    as always thank you Mr Wayne


  • Moderator

    Check server space with
    df -h
    Restart mysql with
    service mysql restart

    Also,
    You need php 7 and modified mysql pass on Ubuntu 16. I’ll find those and post.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.