Multiple FOG installations on one server, which is which?



  • I installed FOG 1.2 to an Ubuntu 14.0.4 server a while back. Worked fine forever. A team mate then installed fog to /root/fogproject and had no problems but when I tried to update to the latest, the version didn’t change on the console. I evidently have two installations and the newest one isn’t the active one? How can I get the trunk install to move to the “front”? Or do I have to rebuild from scratch?



  • @Tom-Elliott Seems to have worked, thank you! Maybe I messed up the trunk upgrade last time somehow. Anyway, I’m showing 1.3RC now so that’s all I’m worried about


  • Senior Developer

    @gwhitfield Whatever location you want. I have no idea where you placed the folder, so mine is just a generic here’s what you can do. If you used /root/fogproject cd to bin in there and run the installfog script.



  • @Tom-Elliott Oooops, before I do that, the trunk install was done under /root/fogproject. Am I still re-installing from /opt/fogproject or from /root/fogproject?



  • @Tom-Elliott I didn’t intentionally put anything in there, the only additions I made were in the /images folder. I’ll try the wipe you suggested and re-install. Thanks, I’ll let you know.


  • Senior Developer

    @gwhitfield I don’t know what you might have, but what I’m referring to would be stuff like ISO’s or something you put in the root of the web directory for FOG or something.

    Otherwise, go ahead and wipe both those locations and rerun the installer.



  • @Tom-Elliott Not sure what info under the web folders is critical that I can’t touch it?



  • @george1421 I do have a bin folder under /root/fogproject


  • Senior Developer

    Simplest fix:

    rm -rf /var/www/fog /var/www/html/fog
    cd /opt/fogproject/bin
    ./installfog.sh -y
    

    Don’t go blindly erasing stuff if you have data you really need to save out of the webdirectories, but this should get things back up and running for you.


  • Senior Developer

    Lemme guess, Ubuntu for server OS?


  • Moderator

    This one has me a bit baffled. FOG is typically installed IN the apache root path (i.e. /var/www/html/fog/… Unless your team mate did something really creative with the apache configs having a web root path in /root/fogproject is not typical.

    Now if you upgrade to the trunk or 1.3.0-rc1/rc2 you would typically use git or svn to download the installer files and then in the ./bin folder run the installer script. If you check that /root/fogproject directory is there a bin folder just under the fogproject directory? If so that is probably the upgrade files not applied to the FOG environment.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.