Windows 7 Without SysPrep?



  • Hey guys/gals,

    I used FOG years ago (probably around 4 years ago or so) - and I loved it. I had it working pretty well within a small environment where I was employed.

    Long story short - new place, new tasks. Setup a FOG server once again! Using .32 ; In my excitement to have gotten it setup and working I created an image of a spare Windows 7 machine we had here at the office just to get back and familiarizing myself with the process.

    I did NOT sysprep or run FOGprep before creating the image. It’s a single partition resizable ntfs image.

    I pushed it back out to the same machine - (again, to test); I got the Windows Boot Manager error:
    Windows failed to start, etc etc.
    Status: 0xc000000e
    Info: The boot selection failed because a required device is inaccessible.

    My question is this: Is there a way to make this machine bootable from this image WITHOUT having to reinstall Windows 7, sysprep and take a new/different image? I’ve searched and have come up relatively empty handed - but if there is a way to do this, I’d like to know just in case we ever get in a situation like this with a PC that isn’t a test.


  • Banned

    This post is deleted!


  • I’ve had the same issue, finally it works for me, Win7 cloning without Sysprep.

    My setup is :
    [LIST]
    []Lenovo Edge 72 3493 (Core i3 + 4Gb ram)
    [
    ]HP ProLiant ML 150G3 FOG 0.33b server
    [*]Windows 7 Volume licence MAK installed with applications, no Sysprep
    [/LIST]
    [B]1st try :[/B]
    Installed my master machine (EDGE-TECHNO) with all applications
    FOGPrep master machine + bcdedit commands
    –> ends up with a bizarre state “Missing Boot Record”… I used Ultimate Boot CD to fix MBR

    • fix BCD + fix Boot section, nothing works… Finnally i saw that little USB key in the back of
      the computer i just forgot to remove… (2h lost)

    [B]2nd try :[/B]
    Fixed my error, MBR OK, Master computer image booting, etc
    FOGPrep master machine --> Upload to FOG Server (took 38 minutes)
    Deploy the image on a second computer (EDGE-SPARE), took approx 3 minutes (speed up to 4,7Gb/min)
    Ends up with “[…]\winload.exe 0xc00000e” error we all know about

    I can fix that easilly with Windows 7 install DVD but my goal is to clone 18 computers

    [B]3rd try : [/B]

    Changed the image type from Windows 7 - “Single Partition (NTFS Only, Resizable)” to Windows 7 - "Multiple Partition Image - Single Disk (Not Resizable)"
    FOGPrep master machine --> Upload to FOG Server (took a 40 minutes)
    Deploy the image on EDGE-SPARE, took around 3 minutes
    Reboot after cloning, works like a charm !

    It takes a little more disk space on my server but it now just works fine, join the AD and so on !

    Hope it can help someone here to clone correctly without having the 0xc00000e error =)

    Alex



  • I’ve had the same problem here, because I like to do most of my Win7 image preparation in VirtualBox, then clone my generic VirtualBox image to specific hardware BEFORE running sysprep. [Finally I install hardware- or classroom-specific software, run sysprep and capture.]

    But this winload.exe error has been forcing me to “recover” each pre-sysprep clone, which is time-consuming (and labels every system here as “recovered” in the boot loader). After trying every combination of fogprep, bcdedit and regedit I could find, I did some deeper investigation (including trawling through the BASH scripts that make FOG work, comparing MBRs byte-by-byte, etc.), and I determined that the problem was in the BCD (Boot Configuration Data). The bcdedit commands described here and elsewhere don’t work, because they don’t instruct the boot loader to search anywhere for anything.

    I wasn’t able to find bcdedit commands to replicate what sysprep does to the system BCD store, but here’s what I did to achieve the same result (using VirtualBox snapshots):

    1. Capture a snapshot of a working audit-mode Windows 7 machine. 32-bit or 64-bit doesn’t matter - the BCD data seems to be interchangeable.
    2. Boot your machine, open a command prompt and run: “C:\Windows\System32\sysprep\sysprep /generalize /quit”. The /quit is important; you want the machine to stay up after sysprep so you can collect the BCD store as sysprep leaves it.
    3. If curious, run: “bcdedit /enum”. You’ll see what sysprep has done to your BCD store.
    4. Capture your BCD store: “bcdedit /export C:\generalized.bcd”. Save the resulting file with your other deployment files; mine ends up living in C:\Windows\System32\sysprep alongside my unattend.xml etc.
    5. Feel free to discard the sysprep’d virtual machine. Restore to your step 1 snapshot or similar.
    6. As part of your FOG pre-capture workflow, when not using sysprep, run “bcdedit /import generalized.bcd”.

    I hope this helps someone!



  • Fixed it - I had to run the install disk and head to the recovery console. It immediately found the issue and fixed it. Was able to boot into the image fine after that.

    Now I can fogprep and reupload the image the right way :)



  • I had stumbled across that. My issue is that I already uploaded the image and deployed it to 1 PC (the same one from which the image was uploaded).

    I went into the PC with Hirens Boot CD and deleted those registry keys and tried to reboot but got the same issue. I can’t get into the system in order to run those commands.

    Just curious if there is a fix for this without reinstalling windows; or if I am hosed to the point I need to reinstall everything manually.


  • group:cid:13:privileges:mods:members

    You still need to remove a registry key for this to work. Here’s an exert on what needs to be done:

    Right before uploading the image the MountedDevices registry key must be cleared. If it is not, the master image and subsequent deploys will result in this problem: [URL=‘http://www.fogproject.org/wiki/index.php/Vista_Image_says_0xc000000e_\windows\system32\winload.exe_can_not_be_loaded’]Vista Image says 0xc000000e \windows\system32\winload.exe can not be loaded[/URL]
    This can be accomplished by [I]any [U]one[/U][/I] of the following methods:
    [LIST=1]
    []use Sysprep with the /generalize switch
    [
    ]run [URL=‘http://www.fogproject.org/wiki/index.php?title=FOGprep&action=edit&redlink=1’]FOGprep[/URL].exe
    []manually delete the ??\volume{…} keys in the registry under “HKLM\SYSTEM\MountedDevices”
    [
    ]run the following from an administrator’s console:
    [/LIST]
    bcdedit /set {bootmgr} device boot
    bcdedit /set {default} device boot
    bcdedit /set {default} osdevice boot

    taken from: [url]http://www.fogproject.org/wiki/index.php/What_do_I_have_to_do_to_an_image_before_uploading%3F[/url]


Log in to reply
 

344
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.