Memtest fails from UEFI menu



  • From the FOG menu I can run Memtest from the legacy BIOS boot clients, but it fails to start from UEFI clients’ FOG menu.

    2e008081
    exec format error
    chainloading failed

    Any idea what is causing this?

    thanks, -kurt



  • I’ve set the FOG_MEMTEST_KERNEL in the General Settings to memtest.bin with no luck, same error. There is a file called “memdisk” in the same folder, it errors in the same way.


  • Senior Developer

    @george1421 iPXE memtest doesn’t work using the syslinux version. There’s a separate file called memtest.bin as a part of the ipxe directory.

    @kurtblah are you using the memtest.bin file or the syslinux memtest file?


  • Moderator

    @kurtblah refind.efi is the last chance option to get it to work as you need.

    If no other uefi exit mode works for you as your test then you can set the FOG global exit mode to refind. You can edit the refind.conf file found in /var/www/html/fog/service/ipxe directory to change its options if the default do not work. I personally haven’t needed to use refind as an exit mode, but I also only have a few uefi clients in my environment.



  • Yes. the Memtest ISO boots fine from a USB drive via UEFI.

    I am wondering, are other users having this same problem with the FOG installed Memtest when booting as UEFI clients? I’d like to know if my environment here is playing a role here.
    Are users with UEFI clients needing to set their PXE menu exit to REFIND_EFI in order to boot to the disk from the FOG menu? For me its the only way to get the our machines into the OS from the boot menu.


  • Moderator

    @kurtblah I’ll have some time tonight to play with the new iso. I’m sure they are still using the same concept. There should be one that is the linux kernel and one file that is the virtual hard drive. If they are still using syslinux to boot that iso there should be a syslinux.conf in that iso file. That will tell us what is the kernel and what is the inits.

    But as Quazz said memtest 5 should support uefi. If you use rufus and burn that iso image to a usb flash drive does memtest run from the usb flash drive?



  • Nope, its off.


  • Moderator

    Memtest 5 and newer should support UEFI.

    Is Secure Boot enabled per chance?



  • @george1421 The new 7.0 memtest ISO does not have those two files (memtest and memtest.bin) within it. The 7.0 version is a different beast it seems.


  • Moderator

    @kurtblah So what happens if you were to replace the 2 memtest files in /var/www/html/fog/service/ipxe with the current ones. You will need the kernel and the virtual hard drive files. They must be replaced together.



  • @george1421 memtest 5.01 comes up from the BIOS boot menu. Memtest site latest version is 7.0.


  • Moderator

    @kurtblah If you boot using bios/legacy mode can you glean the version number of memtest shipped with FOG? (I don’t have access to my fog server right now to try). How does that compare with the current version on the memtest site?

    [edit] lets also make sure its not a 32/64 bit issue too.



  • http://www.memtest86.com/technical.htm#network

    Perhaps their “Site Edition” is needed for this?

    http://www.memtest86.com/features.htm


  • Moderator

    @kurtblah So then does memtest.bin need to be uefi compatible for some reason? That is just an open question. I have really never tested memtest on a uefi system to even see if the one that is shipped with FOG is compatible with uefi.



  • With REFIND_EFI as the exit type I can boot to the hard diskand successfully run the other options, but when the MEMTEST option is chosen I get the chainloading error. The exit type does not have an effect on the Memtest behavior, it gives the same error regardless of the exit type set in the PXE Boot Menu settings within the web gui.


  • Senior Developer

    @kurtblah So using refind exit type you aren’t getting chainload error?



  • Sorry, should have mentioned that I am using 1.3.0 RC1.

    UEFI clients need to be set with the REFIND_EFI exit option to boot to the hard disk.


  • Moderator

    What version of FOG are you using? If you are on anything earlier than the trunk build r4500 then I can understand this error since the 1.2.0 did not support uefi very well, more specifically the version of iPXE that shipped with 1.2.0 did not support uefi very well.

    Please upgrade to 1.3.0-rc1 for better support of uefi systems.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.