Domain Error! Unknown Error 2241



  • I’m currently trying to make the last leap into fog and getting AD integration working. I’ve set it all up, and the handful of machines I’m testing it on are all returning an error -

    HostnameChanger Domain Error! (‘Unknown Error’ Code:2241)

    Any ideas? I can’t find any references to that specific error code anywhere, and I’ve double checked the settings and they all seem correct. I’ll include them below in case I’ve stuffed something up (which is entirely possible :-))
    Domain: levelA.company.local
    OU: OU=new,DC=levelA,DC=company,DC=local
    Username: levela\fogjoin
    Password: encrypted by FogCrypt


  • Moderator

    In my setup, our domain is “domain.loc”

    My Active Directory Defaults settings, under Other -> Fog Settings in the Web UI are:
    FOG_AD_DEFAULT_DOMAINNAME: domain.loc
    FOG_AD_DEFAULT_OU: [blank]
    FOG_AD_DEFAULT_USER: domain\username
    FOG_AD_DEFAULT_PASSWORD: [FOGCrypted password]

    Also, make sure the account you are using is a member of the domain group BuiltIn\Account Operators, is a member of Domain Admins, OR has been delegated rights to add, delete, and manage computer accounts in the default “Computers” container and any other container in which you want to create computer accounts. I think there is a 10 computer limit on normal accounts adding computers to the domain.



  • [quote=“chad-bisd, post: 4118, member: 18”]Have you tried joining them to the default computers container, i.e. leaving the OU field blank?[/quote]
    Well, that fixed another of my problems (error 1392 i beleive) - think it had to do with the comp name already having an account in another OU. However I’m now having problems with error code 1323 (wrong password). I’ve checked the account (it can log in fine), I re-ran the encryption (and tried it unencrypted), and I’ve followed the wikis convention on usernames (and tried a few more variations).



  • FYI, code 2241 is a reference to login avalibliy of the user account (One of the other admins set the account login hours to block at all times. Further Problems still being encountered


  • Moderator

    Have you tried joining them to the default computers container, i.e. leaving the OU field blank?


Log in to reply
 

368
Online

38983
Users

10712
Topics

101680
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.