HP ZBOOK15U G3 - Host Registration Problem



  • Hello. I have an HP ZBook 15U G3 that refuses to register. When I get to the FOG boot screen and do a full register it says “Unable to register host for the following reasons” but it never gives any. It then goes through the inventory process and recognizes everything. Then it goes to “Attempting to send inventory” and that’s where it just hangs.

    I’m on version 1.2.0 and I’ve downloaded the latest kernels from the below links and put them in my ipxe directory.
    https://fogproject.org/kernels/bzImage
    https://fogproject.org/kernels/bzImage32

    I’ve also disabled the UEFI boot in BIOS.

    Any help would be appreciated. Thanks!


  • Moderator

    @phishphan said in HP ZBOOK15U G3 - Host Registration Problem:

    I ask because once I have my captured image I move it to another drive for archival.

    You should automate that with a cron task and scp or rsync.


  • Moderator

    @phishphan The post download scripts are not image dependent. This directory is the location to install custom bash scripts that can be called by the FOG server during image deployment. Everything for the image is stored in the image directory.



  • I’ve got the hosts imported. I have quite a few unique images but with 1.3 up and running and it working with my HP Zbooks I’m more than happy to do a little legwork.

    Last question - is the “postdownloadscripts” folder image dependent? I ask because once I have my captured image I move it to another drive for archival. I just want to make sure when I need to pull it up again I have all the components.


  • Moderator

    @phishphan 1.2.0 can’t export those other things, but you can do a total configuration save if you really needed to, and import that to the new server. Lots of stuff will need changed, like IP addresses, passwords, and maybe paths - after import is complete.

    You can also individually export tables, but if you do this, you won’t get the schema information that fog needs to update the layout and you’d have to do this manually and it might be quite involved. It’d be easier to take a total configuration export and then import that and make the necessary IP changes for it to work on the new and different server.

    How many images do you have? Would it be that difficult to just manually make the definitions?

    @Tom-Elliott since this keeps coming up, maybe we can produce a script for 1.2.0 and perhaps .32 that would export images and groups in the appropriate format accepted by fog 1.3.0 ?



  • @george1421 On the Hosts page I see the option to export but in Images and Groups I don’t see any option to export. How would I go about getting that data?


  • Moderator

    @phishphan The other thing you will need to export and import are any image defintions and to move any captured images from your old FOG server to your new FOG server. You will need to do the same if you have snapins too.

    As for your environment, don’t forget to update your dhcp server (option 66) to point to your new FOG server.



  • @george1421 Okay, I’ve got 1.3.0-rc2 installed on 14.04 and it’s up and running. I’ve exported my hosts from the previous version. Please advise on what other configuration files I need to bring over to get everything back in order.


  • Moderator

    @phishphan There is a way to migrate your data.

    What I would suggest that you do install Ubuntu 14.04LTS. FOG will install without issue on this platform. Then we can work on migrating your data. At this time the trunk build will be 1.3.0-rc2 (which is a good thing). There is no reason to install 1.2.0 stable and then upgrade, install the 1.3.0-rc2 directly.



  • @Tom-Elliott

    So I haven’t had any luck installing curl. If I upgrade to a different Ubuntu on a fresh VM is there an easy way to import all my custom configs to the new version of FOG? As mentioned, I’m a Linux noob and it took me a lot of time and tinkering to get FOG up and running.



  • @george1421

    ubuntu 13.10 64-bit, Intel I-5, 7.3 gigs of RAM in a VM.


  • Senior Developer

    @george1421 nope I has voice to text


  • Moderator

    @Tom-Elliott said in HP ZBOOK15U G3 - Host Registration Problem:

    @george1421 that’s what I asked about earlier as well. Now I’m driving home lol

    Do we need to have a discussion about texting and driving???


  • Senior Developer

    @george1421 that’s what I asked about earlier as well. Now I’m driving home lol


  • Moderator

    @Tom-Elliott I don’t think I saw what host OS FOG is running on (Ubuntu I saw that but what release)


  • Senior Developer

    @phishphan Then we need more info.

    Why isn’t curl able to be installed?



  • @Tom-Elliott

    I ran that command and then tried again and I got the same error message –

    Installing package: curl…Failed!


  • Senior Developer

    @phishphan What Ubuntu version are you running?

    Can you run: apt-get clean all && apt-get update && apt-get dist-upgrade? and see after the updates happen if curl will install properly?



  • So this is what happened after I ran the command root@ubuntu:~/Desktop/fogproject-1.3.0-RC-1/bin# bash ./installfog.sh As you’ll see below the “curl” package fails to install. Any thoughts on why that would be happening?

    • Here are the settings FOG will use:

    • Base Linux: Debian

    • Detected Linux Distribution: Ubuntu

    • Server IP Address: 192.168.1.2

    • Server Subnet Mask:

    • Interface: eth0

    • Installation Type: Normal Server

    • Donate: 0

    • Internationalization: 0

    • Image Storage Location: /images

    • Using FOG DHCP: No

    • DHCP will NOT be setup but you must setup your
      | current DHCP server to use FOG for PXE services.

    • On a Linux DHCP server you must set: next-server and filename

    • On a Windows DHCP server you must set options 066 and 067

    • Option 066/next-server is the IP of the FOG Server: (e.g. 192.168.1.2)

    • Option 067/filename is the bootfile: (e.g. undionly.kpxe)

    • Are you sure you wish to continue (Y/N) y

    • Installation Started

    • Installing required packages, if this fails
      | make sure you have an active internet connection.

    • Adding needed repository…OK

    • Preparing Package Manager…OK

    • Packages to be installed:

               apache2 build-essential cpp curl g++ gcc gzip htmldoc lftp libapache2-mod-php5 libc6 libcurl3 m4 mysql-client mysql-server net-tools nfs-kernel-server openssh-server php5 php5-bcmath php5-cli php5-curl php5-fpm php5-gd php5-json php5-mcrypt php5-mysqlnd php-gettext sysv-rc-conf tar tftpd-hpa tftp-hpa vsftpd wget xinetd zlib1g 
      
    • Skipping package: apache2…(Already Installed)
    • Skipping package: build-essential…(Already Installed)
    • Skipping package: cpp…(Already Installed)
    • Installing package: curl…Failed!
      root@ubuntu:~/Desktop/fogproject-1.3.0-RC-1/bin#

  • Moderator

    @phishphan are you on version 0.32 or 1.2.0? If you are on 1.2.0 there is a wiki page that is pretty good. https://wiki.fogproject.org/wiki/index.php/Upgrade_to_trunk

    The idea is you download the trunk version (which is actually 1.3.0-rc1 right now) and then run the installer from the bin folder. It will upgrade your current 1.2.0 release to 1.3.0-rc1


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.